Ps4 patch/hotfix 1.2.5 (1.04)

I dont care so much for the lockpickin even though I’ve wasted over 100 lockpicks and still haven’t been able to open anything yeah its super frustrating, but i rather see the bugs and quests fixed first, im 46+ hrs into the game and i cant continue with the main storyline to fight runt and get the sword back, and if i want to go back to the start of nest of vipers i need to load a save 16hrs into it, im not doing that, hopefully they bring out the actual patch soon.

The lock picking isn’t that hard on ps4, I don’t understand the complaints


Ok so I’ve downloaded the patch now and guess what? The R2 still does not work. What am I to do? I’ve been using L2 so far but it just feels wrong. And the torch thing pisses me off too.

How did the Patch affect Stealth?

I’m sorry, but for a game that cost 60 bucks, and is for the PS4… I terribly disappointed. The story is great. But, between the glitches, cluck and bugs… Terrible. There are games from the 90’s, that are smoother… I won’t buy another of this studio’s products, EVER!


I really wasted a lot of time for trying to play that game. nothin about lockpicking or pocketing or so. i am the dumb son of a smith, so i am just a fool and i have to lern everything. that is ok fpr me.

but all the other stuff. r2 works one time and two times not. no combos possible. lot of bugs in the game.
waiting for updates, loading more than FOURTY gbytes on patches and still a lot of crab. hours and hours of downloading pathes. now - with 1.2.5 the torch is glued to my left hand. and the savegames of version 1.2 are not really compatible. tell me one single reason why i should waste more time on this crabby game, witch looks excellent but is full of bugs and glitches. i payed for this ok? i did not find this in the sewers. i worked, i earned money and i spent it for this waste of time!

1 Like

New patch broke torches. Can’t hold left to bring it out or put it away. Hopefully this is fixed.

1 Like

i thnk they may have intially uploaded the wrong patch for ps4 today

there was a 380mb 1.04, now theres an all most 3.2GB 1.04 thats downloading on my ps4.

Its almost as if the person responsible for uploading the patches has confused themselves due to different naming convetions between pc an console.

some are reporting that even though they downloaded 1.04, the game states 1.2.5 in the menu.

Fucking hell… must be nice. Xbox One doesn’t even have the HOTFIX patch yet. (1.2.5) -_-’’’’’

1.04 is patch 1.2.5. It fixes the R2 issue, but ironically it broke torches.

1 Like

Since I trained a bit with Peshek, and then bought one level of training from him, opening easy locks works well for me on PS4 with stock controller…

Not darn easy, but I usually manage. Finally a game where I don’t have to skip upgrades, and skills to be able to enjoy it, we don’t need another Asassins Creed or any game with similar -abolutely dumbed down- difficulty. I love AC games, but since Brotherhood, all of them dead easy… Origins can pose some fun for a while but I still need to skip skills… At least here you either need to PRACTICE and get better in real life, or SPEND ingame money to buy skill levels… I usually suck on hard games, but htis game is jussssst perfect. If you practice enough, you get better IRL, if you are lazy, you can buy the skills… A perfect scheme. Please do not spoil it as whiners did with ALL the normal difficulty games at the past, for example with most MMOs that became boring easy… practice OR buy the skills. until it gets easy enough to perform it…

1 Like

Can we not complain about the lockpicking. At first ya it’s difficult but once you get lol 4 easy locks become really easy lvl 8 hard locks are a joke at lvl 15 you can do very hard and still break a pick if you aren’t careful. System works fine. The left analog stick just made could respond a lil better. But if they make it any easier might as well just remove it from the game a leave everything unlocked as that’s what it would be like. I playy on ps4.


R2 still not fixed.

Fixed for me my r2 is working fine now. Vagabond quest still bugged for me tho

Mine work. The only complaint I have now are the torches. I hate that these patches fix one thing but breaks another.

The lockpicking is hard, but not impossible! This is a life realistic game, you need to practice if you want to be better and better - just like real life. When I started the game I cannot opened a fucking chest half an hour! Try to turn off the vibration of your controller, practice in Phasek place there is a training chest, you also can training pickpocketing with him.
Just practice and be patient, never give up it will be easier!!


Actually the left stick works perfect: you start by pushing to the top (up) edge, KEEP IT ON THE EDGE, and while holding it on the edge, like licking a cup’s inner side XD perform a dead slow circle… Aaaalll around, always kgeeping it on the maximum. Do not leave the edge… The right stick just there to be adjusted not to leave the golden area, I usually find it useful to pause for a while with teh left stick until I can find the biggest golden circle again, then continue, instead of just focusing to keep it golden

1 Like

Everytime they release a new patch, they release a new bugs too. Lol.


Might be might be my paddle then. As I find the left stick slightly un reponsive

This is funny, but sadly true… :frowning:

1 Like