Alienware 17 - uses only integrated GPU


#1

I have the Alienware 17 (2014 version) with two GPU´S, integrated Intel HD graphics 4600 and dedicated AMD Radeon R9 M290X. But even I set the AMD card to be used to run KCD, the game still uses only Intel GPU. I don´t know how to force the game to use dedicated card, and it´s really sad that $1,499 machine runs the game on average 9 (!!) fps. I am still using windows 7, maybe that´s the problem, I don´t know. Any ideas?

Thank you


#2

Do you use the latest AMD driver?
Can you force it in the Bios to use the grafic card?
Same problem with other games?
Alienware helpdesk?


#3

We need a little bit more Info to help you.
Tell us ur specs…

CPU, Mainboard, ect…

Also you should install newest AMD GPU Driver:

https://www.amd.com/de/support/graphics/amd-radeon-r9-series/amd-radeon-r9-200-series/amd-radeon-r9-m290x


#4

The only Thing i remember is the FN + F7 Key combination (Alienware OSD Software must installed)


#5

Might be a little bit risky, but I’ve done it on my PC. I disabled the integrated graphics in the device manager. Also you can go to I think either energy settings or nvidea control panel to select a designated GPU for a specific programm


#6

He has amd and no nvidia. And there’s nothing risky about switching to dedicated gpu. It’s the normal thing to do when you have a dedicated gpu imo


#7

Ah my bad. Yeah I’m not that well versed in computers if I’m honest