Annoying pop ins


#1

Hi I am unable to play KCD because of terrible pop ins:

  1. npc & animals spawn in a 150-200 meters of me right in front of my eyes.
  2. Far shadows casts in 500-1000 meters right in front of my eyes.
  3. grass spawns in a 150 meters right in front of my eyes.

In other words world is detailed only in 150m around of player and looks horrible in a far away. And when I ride a horse it looks like in a night club - object just suddenly appers.
I have tried a lot of configurations to fix it including a console comands and texture streaming.

my configuration:
9900K + 2080 Ti + 32GB + nvme ssd 970 evo

CPU utilization is around 20%. Mem usage is around 4-6gb. GPU MEM usage is 6gb.


#2

Well ur hardware is best of the best I think only way is to tweak those distance numbers in cfg file or somewhere. Game just does that, btw someguy told me that better ssd would make difference but i didnt believe him he said evo ssd s are crap.


#3

Yes I m trying to find it in cryengine doc but without any results.
btw evo is ok.


#4

Hi. That should not be happening, especially with your system.

However, that doesn’t make it “unplayable”. 150m is not near. What you mean is that the performance of the game is annoying and frustrating, and there’s no obvious or logical reason for it. Still, the game is perfectly playable. You simply cannot stand to play it due to the inexplicable and gross graphical issue, and while I agree I would not like to play that way either, saying it is “unplayable” is neither helpful to solving your problem nor is is accurate.


#5

technically it playable. but it is not so enjoyable it could be.
UPD:
4) chickens apperas in 15 meters of me
5) some indoor stuff like glasses, plates & bottles appers in 2 meters!!!


#6

No mention of the detail level? Turn the detail level up. Your PC can handle it. It’s been a while, but I’m pretty sure it’s in settings from the main menu screen when you first load the game.


#7

Yes those plates & bottles spawn 2 meters in front of u even on max sliders and that happen at every places where are those items pretty much all camps :confused:


#8

Isn’t there a graphics mod which allows u to set extreme graphic settings?
Maybe this would help.


#9

Objects, texture and vegetation are set to highest (not ultra) preset. Other settings set to medium (cant set it higher as soon as I play at 4k due to huge fps drop). I have also tries ultra at 4k or utltra at 1080p and has the same result.
All three lod slider are maxed too. Extra config below:
r_ssdo=1
r_ssdoAmountAmbient=1.4
r_ssdoAmountDirect=2
r_ssdoAmountReflection=4
r_ssdoHalfRes=2
r_ssdoRadius=0.04
r_ssdoRadiusMin=0.07
r_ssdoRadiusMax=0.1
e_svoTI_SSAOAmount=1.545
e_svoTI_SpecularAmplifier = 0.82
e_svoTI_TemporalFilteringBase = 1
e_svoTI_MinReflectance = 0.19
e_svoTI_DiffuseAmplifier = 1.12
e_VolumetricFog=1
sys_MaxFPS = 60
r_VSync = 1
r_MotionBlur = 0
r_Sharpening = -1.2
– LOD
e_ViewDistRatioVegetation=1000
e_ShadowsCastViewDistRatio=1
– View distance ratio for special marked objects (Players,AI,Vehicles)
e_ViewDistRatioCustom = 400
e_ViewDistRatioDetail = 300
e_ViewDistRatioLights = 1000
e_ViewDistRatio=400
e_LodFaceAreaTargetSize=0.0008
e_UberlodDistanceRatio=4.0
e_MergedMeshesViewDistRatio=125
e_vegetationUseTerrainColorDistance=150
e_ShadowsMaxTexRes=2048
– Hyperthreading options used
r_MultiGPU = 0
r_MultiThreaded = 1
sys_job_system_enable = 1
ai_NavigationSystemMT = 1
sys_job_system_max_worker = 0
– get rid of texture pop
r_TexturesStreamPoolSize = 10096
sys_budget_videomem = 10096
r_TexturesStreamingMaxRequestedMB = 2300
sys_budget_sysmem = 28000
e_StreamCgfPoolSize=1024
r_TexturesStreaming = 1
r_texturesstreamingDeferred=1
r_TexturesStreamingResidencyEnabled=1
r_TexturesStreamingMipBias=-3
r_TexturesStreamingResidencyThrottle = 0.8
r_TexturesStreamingResidencyTime = 120
e_AutoPrecacheTexturesAndShaders=1
e_PreloadMaterials=1
e_PrecacheLevel=1
e_StreamPredictionAhead=1
sys_PakStreamCache=1
sys_preload=1
r_antialiasingmode=0
r_antialiasingtaasharpening = 0


#10

I’d try low settings and see if the popin is better or worse, then start ramping up to ID the culprit.

KCD is horridly optimized. I had hoped that the modding community would address this in some way by now.


#11

e_ViewDistRatioCustom = 400
e_ViewDistRatioDetail = 300
e_ViewDistRatioLights = 1000
e_ViewDistRatio=400

Try modifying those one at a time until you get it working with less popin. As you said, the ultra setting is experimental, and drastically reduces FPS. I found putting it on high increased the popin distance dramatically, but it was still there.


#12

Has tried already. Does not helps with my problem.


#13

Wish I could help. all I can say is, I have a system which is likely “lesser” than yours, but I don’t really notice this problem. Only time I notice something that seems to resemble what you are describing is if I put the game on really high demand settings and then gallop at top speed into Rataje or otherwise Rush my camera reference point through the gameworld.

MSI MS-7821 mobo, Intel i5-4690K 3.5GHz, 8GB RAM, Win7 / NVIDIA GeForce GTX 970 3.9GB

It is an Indie game, their first project with the engine. Given that AAA studios with cumulative design experience levels in the thousands or tens of thousands of years ballpark can put $60 products on the market which are even more horribly “optimized” (whatever that actually means) the fact KCD has some hiccups doesn’t strike me as the least bit surprising. Those are the standards at present.

Developers largely ignore the fact that: people will buy millions of copies of graphically low-fidelity games like Minecraft, or Rimworld, or insert name of a score or hundred other similar games which are musth less challenging to tune for good performance and understandably we all like pretty graphics, but then when the chickens of performance degrading come home to roost it is a problem . . .