Bath House - am I missing something?

I feel kind of silly for asking, but how exactly are you supposed to use the bath house? I think my game is glitched, but I want to make sure I’m actually doing it right. I talk to the woman and select the option I want and pay for it, and nothing happens. So I walk out back to wear the tents are with the tubs in them, and when i stand next to one the “sit” option comes up, but when I hit X, my character completely freezes. When this happens, I can’t bring up the start menu or anything, so i have to completely close the game and reopen it, which loads from my previous save point.

i have this game on both pc AND ps4 and it’s doing it for both of them, but i couldn’t find any mention of this from anyone else! Please help.

There should be the “Wait” UI after you pay but with different text. I think the “wait” time was 8 hours or something. After its done you should be back in front of the seller

You can pay for cleaning your clothes, heal your wound, hire a wench on bath and after you choose one of that,it will automatically.

I get a black screen after I pay with a water sound effect but that’s it, and nothing actually happens. It’s supposed to save, too, isn’t it? Because it definitely doesn’t.

No,as i know you can’t save on the bathhouse.Or i didn’t notice that.

Does it say/do something after you pay? Because mine doesn’t. She just takes my money, and in ths PC version nothing happens whatsoever, and in the PS4 version the screen goes black momentarily but as far as I can tell it does nothing.

I dont think it saves but you should get “alpha male” buff
Edit: the buff might be with the most expensive option.

According to all the guides i’ve read, it is supposed to save at the bathhouse.

Is that only for the wench option or all of them? because I don’t get that.

Yes i think so.

If I use the option with the wench, it goes the black screen with woman moaning for couple of seconds. It saves the game and gives me the buff as well as cleans the clothes.

After i’m choosing the wench and bath option,you’ll hear a woman moaning (black screen) after that back to the game again.

I haven’t tried the wench option because I don’t have enough currently, and considering none of the other options work for me i don’t want to waste the money. But I definitely don’t get the wait UI or anything. It just does nothing.

the transaction should be immediate (no black or cutscreens). or the cutscreen should actually be an animated scene

Those are two completely different answers. Also, the other commenter said the “Wait” UI should pop up. So which is it?

See, it is supposed to save:

The ui in the bath works just like the wait ui. Its just a progress bar. I am not sure if it shows in all the options tho.

My only experience at bath house included paying for services to render healing, forget which option it was, but for sure did not include the wench.

The background fades and the UI clock-circle (same UI as the ‘wait’, or ‘sleep timer’ /clock) appears on screen
The option I chose/bartered for had a time progression of 6 hours +- as indicated by the UI clock on the screen front and center.
Edit: I did this in the afternoon, roughy 4pm in game. Have you tried to come back at other hours of the day to see if you have the same results?

I am definitely not getting a waiting UI. I have tried all times of day and all levels (excluding wench). I just wasn’t sure what was supposed to happen to know if it was working. I will report it as a bug. Thank you!

i just try to save with the bath house and it works for me. it will save if you choose “Hot bath, clothes laundered and wounds healed”
it wont if you choose “Hot bath and clothes laundered”