Cannot change resolution ingame windows 10 Epic Games Launcher

I’ve acquired the game via Epic Games.

I can’t change the resolution in any way, it’s hard set to 3840x2160.
Whenever I try to change the resolution with arrows in main menu the “sound” plays and the “confirm change” is whitelighted but the resolution doesn’t change.

I’ve tried following solutions so far:

  1. Changing my native PC resolution to 1920x1080 and then reinstalling the game
  2. Changing from fullscreen to windowed/borderless modes before trying to change resolution
  3. Using Nvidia GeForce Experience to change the resolution and run the game through their soft
  4. Adding a “user.cfg” file with following lines in:
    Attr name=“res_fs” value=“0”
    Attr name=“res_x” value=”1920”
    Attr name=“res_y” value=“1080”
    Also adding “+exec user.cfg” as an additional command line argument.

I’m really out of ideas by now, I contacted Epic Games support thinking it’s launcher’s fault, but they were clueless and sent me here.

What else can I do? I’m using Lenovo Legion Y720 laptop with GTX 1600 and Windows 10/64-bit.

What’s really funny, is that when I run the game through Nvidia Experience, I set the “optimization” to a different resolution and it says that “game is optimized”. Then I start the game, 3840x2160 resolution is shown and when I quit, Nvidia Experience states “game isnt optimized” and the resolution is shown as 3840x2160 again!
It’s like some inbound config file was run right after starting the game to hard set the gamr’s res to 4k… I tried looking in Libs to find if there’s a constant there but couldn’t find anything…