Can't spar with Cpt. Bernard

Hi, I have the following problem:
When I approach Captain Bernard at the combat arena near Rattay, the dialogue option to spar with him doesn’t appear. I’m at the start of the quest Mysterious ways. I already tried waiting and coming back at a different time of day and also going to Talmberg and trying to spar with Sir Robard. (which doesn’t work either)
I let steam validate the game files already, and I deleted the Mods I had installed. After that, I validated the files another time.
The “Training”-option (where you can raise your skills for money) doesn’t work as well. This one does appear in dialogue, but when I click on it, the menu resets and nothing happens. This goes for all characters, not only Bernard.
Thanks in advance for help.
System specs:
Windows 10
Nvidia GeForce GTX 970
Intel-core I7

that is odd
a few NPC’s have been glitching out like this lately, for instance the archery master in Pribyslavits doesnt have a trade option anymore
also sleeping NPC’s are really hard to interact with because even if you wake them up they just dont respond to you pressing e to talk

Get in contact with Blacksmith, best person to help

Can you post a save? Just to test.

That´s definitve not a “normal” bug…
Maybe your save is corrupted.
Have you used a “trainer” (program) before? Which MODs have you used?

What happens if you start a new game? Do you have the same problems?

1 Like

Just an input, I’ve played kcd on pc modded and unmodded recently, no major bugs unmodded, modded, Cpt Bernard, Capon and Divish glitched.

I can’t upload the save here because the file is to large, so I uploaded it to my Google Drive, here ya’ go:

That might be, at least in regards to the Bernard sparring thing, since this worked in an earlier playthrough where I didn’t have mods, but the paid training option didn’t work for me from the get-go, even when I didn’t have any mods installed. I bought the game fairly early on after the release, so I assumed this option was just a placeholder, but it seems other people can use it.


Faster arrows medium improved speed:
Kingdome Come Deliverance Aiming Spread Disabler:
Black Hoods up:
No Trails:
Bow Dot Reticle:

Didn’t have the time to do that yet, but I’m going to try in the next few days.

Try removing the mods and retrying.

I already did. As I mentioned in the first post.
I also let steam validate the game files after that.

Sorry, I just really cba to read such a long post.

Just tested your save at miller Peshek…
Everything normal, could train for money (pickpocketing).
So save is not corrupted.
If this doesn´t work at your installation, you probaly have to delete and reinstall…

1 Like

Aww, man.
Suspected as much.
Well, thanks for your help.

Soo… I have completely reinstalled the game (I did delete the game folder, before you ask) and nothing changed.
I still can’t spar with Bernard, and the paid training option doesn’t work either.
I will try starting a new game, but since you already verified, that the problem doesn’t seem to be with my savegame, I don’t have much hope there.

At this point I am kind of puzzled, because I never encountered a bug before which wasn’t solved by reinstalling the game…
Do you have any further suggestion on what I might try, or an Idea what causes this?

I did the training for you and saved nearby. Now you know masterstrikes…
Check the save

Sorry, no idea…
I hope you can play with this save,…your problem it´s very strange

Well, thank you.
Since I apparently have encountered a problem that defies explanation, I opened up a thread on steam, maybe that will lead somewhere.
Or maybe my new savegame will somehow not be bugged, who knows.

Also: Is there any other place, besides the Steam game-folder and the save folder, where the game stores data?

This two places is all I know…

Ok I finally found the problem, and now i feel kind of stupid: Appearently you can only choose the “training” option by using the enter key, not space key :man_facepalming:

1 Like

Jesus Christ!!! I’ve been in the same rut, I just tried it, and it works. I have like 800 hours in the game and just now finding
this out. I’ve completed the game twice without training with any NPC. Opens up a whole new world! Thanks Jonas!!!