Cold Steel, Hot Blood not loading

Hi,

Currently playing on an Xbox One X, after the trebuchet test, the game becomes stuck in an infinite loading screen. Really sad that after so much time invested it cannot progress past this point :frowning: Ive also noticed people have had this issue for over two years now, any possible info regarding when this may be fixed? Disappointing that such a unique game has been ruined for me :confused:

1 Like

I have the same problem on PS4, infinite loading screen at the start of this quest. I absolutely loved this game but this has left a very sour taste.

I bought the game at launch but decided to take a break to wait for the bugs to be sorted, here I am nearly halfway through 2020 unable to complete game. It seems there a cheat mod on PC to get through loading screen but consoles are screwed. I hope Warhorse patch it but after this amount of time I’m not hopeful.

For what’s it worth when I began recently playing again the experience was far better than launch (so much so that I bought DLC’s as thought game was fixed!). But the longer my playtime went on the texture pop in started to get really bad, I had a couple of other infinite loading screens but going back to earlier saves fixed it. It really seems the games performance deteriorates the longer I played.

I know right? :frowning: An official statement from Warhorse would be nice after such a large number of people seem to be dealing with this game breaking bug :confused: Sigh, still nothing two years later

As much as I loved the game there is no way I’m buying sequel, I’m still unable to find out what happens to Henry and sword during first game! No confidence in the sequel being any better. The game sold well so should have been patched to fix game breaking bugs. The lost revenue of potential returning customers who were unable to complete first game NOT returning to sequel is just bad business sense of the project lead.

Wew I see I’m not the only one with same problem. I’m stuck in same quest with same problem. Dlc’s are the problem I think.

Having exactly the same problem on Xbox One, seems to be all over forums for the last couple of years but still no fix. Guess that’s game over :cry:

Absolutely love this game and I’m desperate to finish it.