Cold steel, hot blood wont start

After watching the test firing of the trebuchet and right as cold steel, hot blood is suppose to start it gets stuck on an infinite load screen. Just black with the spinning load bar. The seige quest objective completes and it gives me the new objective for cold steel, hot blood. The one to talk to sir divish to find out my role in the defense but then it just stays stuck at that black screen after the cutscene. From what I’ve been able to find this has been an issue since the release of the game and the latest patch 1.91 still hasn’t fixed it. Are they ever going to fix this game breaking bug? Literally cant finish the main story now. I wouldnt care so much if it was a side mission but jesus christ. The main story right towards the end?! And it’s still not fixed?! This is crazy. I love the game. Wish more were like it. Besides the damn bugs and glitches. The real shame is I almost had a complete playthrough with out any serious issues until this. Few minor things but nothing to even really complain about. But this wants me either wanting my money back or them to guarantee a fix sometime before the next console generation. Shit I’d honestly probably even pay for the fix at this fucking point just to support the dev’s. Even though that’s so wrong on so many levels that I’d even do that.

Are you on PC or console?

I’m having this issue as well on the PS4 Pro. I understood it would be fixed in the new patch, but, sad to say, it’s still alive and well. The load in the MQ mission Siege goes on forever. (We’ve tried three times and waited and watched as much as a half-hour.)

It’s frustrating not to be able to play a game I love this much and I suppose restarting is an option. but I must have nearly 250 hours invested. I don’t want to throw that away.


1 Like

I’m on xbox one

I feel ya. I have 364 hrs in my 1 playthrough where this bug is happening. I’ve started a 2nd playthrough now but honestly the same bug could happen again. If it does then I’m really gonna be pissed. But hopefully it wont but it does suck to throw all that previous game time away basically. I loved my henry build on my 1st playthrough. I made sure to make all the right decisions to get the outcomes I wanted and the perks I wanted and everything. I had even done all the dlc content besides the womans lot dlc. I was going to do that dlc after I finished the main story. Its heartbreaking honestly.

Playing the Royal Edition on Xbox One X during first playthrough with all DLC installed. Game did the same thing after the trebuchet test. I’ve quit the application a few times and restarted the console. I’ve advanced the time to different points throughout the day. As a last resort I uninstalled everything and reinstalled. None of these attempts worked and while I only experienced a few loading issues during my playthrough (which were solved by restarts or closing the game), this bug completely stopped my progress. It’s unfortunate that it’s a game breaking bug identified many months ago and it’s yet to be fixed. There was nothing for console players I could find that fixed this issue.

1 Like

I feel your pain. I had an identical situation to you. As well as the prior bugs being minor and needing only a restart of the console to get back on track. This problem though is really irritating especially since it’s been a known issue for a very long time now.

1 Like

I too feel your pain. I am sick of the bugs and lack of updates. It has got to the point where i have finished all my side quests including all the DLC ones and now CANNOT continue.
You can guarantee i will not be buying anything else from from warhorse…this sucks.

I am also having this same problem but I am playing on PC. Anyone have a fix for this?

Ok, I found a solution for PC players from a youtube poster, Sir Andi, you have to download the cheat mod from nexus mods then type cheat_save during the long loading screen to save the game. Then restart the game using that save and it will load the next scene. Cheat mod is here:

1 Like

Any luck? Have you fixed the bug and able to finish the game? :confused:

What about for consoles??

Yeah right??? My kcd adventure ended today… Not a mere thing to do to advance from this or fix it… I am mad and heartbroken… Give us our money back warhorse fix the game!!! 2020 still henry is waiting to kill these bastards… Hopeless… :roll_eyes:

Also playing the kdc royal addition on ps4 and seems to still be an issue… Just as things are getting good

1 Like

I really hope they give a patch to fix this… I was in the zone… Then infinite loading screen comes in and ends my story… Are you listening warhorse!!! :expressionless::cry:

Really disappointing to get to the climax of the story and not be able to finish. I’ve let it sit overnight in case it was a longer than normal load and no progress on the outer red progress ring. Up to this point it has been a great game but this bug really negates all the good. Would love to know how it all ends