Console Command to adjust time passage?

#1

Simple question: is there a parameter for which the game is prepared to accept new values that can adjust the rate at which time passes in the game?
For example, in Bethesda’s Creation Engine games, something like:
set timescale to 1
changes the rate of time passage to 1 second in game per 1 second on the hardware. I believe the default in most of their games is around 30 (so each second on hardware is 30 seconds in game), and I often find this to be too fast for my tastes so I adjust it down to something like 8.
I haven’t used a stopwatch to assess what the actual values are for KCD, but I’d guess the ratio is around 20?
While the need for a daily routine is essential to the games flavor and a value of 8:1 (like I’ve often used in Fallout 4 or Skyrim) would be too slow, I would like to see if 12 or 15 felt a bit better (assuming the ratio is in fact ~20).

ADDIT: Ah, I found this old thread and the post by Lieste where he refers to adding a new line to RPGparams.xml sounds intriguing . . .

#2


I found the file in question
D:\mirror\Steam\steamapps\common\KingdomComeDeliverance\Data\Tables.pak\Libs\Tables\rpg
and used 7zip to add a new line to test a modified time passage ratio.

Accessing the nodes in that address up there which are “children” to “Tables.pak” requires a compression/decompression app like 7zip, etc. But with one of those, you should be able to “View Archive” (a .pak file is just a type of compression archive, simpler to a .zip or .rar I suppose), and then edit the file. Pretty simple change and easy to reverse if the application shits the bed as a result of it . . .

I didn’t fully understand what Lieste was talking about (and still don’t know where he came up with the actual parameter name he refers to) but after searching that file for “time” and not finding anything referring to “DefaultWorldTimeRatio” I simply copied Lieste’s inclusion line and pasted it below the last line in the xml file

<row rpg_param_key="DefaultWorldTimeRatio" rpg_param_value="8" />;

Apparently the game-time to real-time ratio is 15: 1 (not 20 as I had guessed) and while Lieste set his to a value of “2” that seems too much of a change for a first try to me, so I set my line as above to 8 to 1 and will see how that runs . . . assuming the app actually runs with that added! :grinning:

#3

I could be wrong, but I think these two lines in system.cfg should do what you’re after.

– max time delta (our Timer.cpp change will apply this even to scaled framtime)
p_max_world_step = 0.25
t_MaxStep = 0.25
Just ‘save as’ user.cfg and diddle away. Again, I could be wrong, but I seem to recall playing with this in beta.

1 Like
#4

Ah thanks! I will try those.

I timed an hour immediately after (well, a day or so in game after) making the above xml file edit and: no change. 4 minute (real time) hour.
Hopefully what you’re suggesting will work!
Will report back if it seems to.

#5

Hey @bloodysod I added those two lines to my user.cfg (already had one for some mods), and timed one hour shortly after (maybe not even one complete in game day I don’t recall) and still 4 minutes for one in game hour.

I suppose I need to let it complete the “time cycle” it is in before the change takes effect. That might explain it. Or it could be innumerable other explanations. Anyway, here is what the full contents of my user.cfg looks like

wh_horse_CameraCentering = 0
r_motionblur=0
p_max_world_step = 0.25
t_MaxStep = 0.25

No two language/external call syntaxes are identical, so it might be I have done something wrong there; but that looks like nice simple stuff so it seems like that should work?

ADDIT: I think I might have found my problem, which occurred to me to look for since I’m not even sure the other to param changes i already had in there have been working . . . did a search on “how to user.cfg KCD” and found this thread:

The guy commented that, to get the user.cfg to activate, you have to add an appropriate bit to the “Steam Launch Options”

+exec user.cfg

I vaguely remember using these type of things before. For Steam games, you gotta set it in your library I think: right click game, Properties / Set Launch Options button
then I plugged that command line bit on there. We’ll see if that makes it work!

#6

Damn, sorry about that. I completely forgot about needing to add that line to launch options. Anyway, I hope it works for you. Cheers.

1 Like
#7

Well, it still doesn’t seem to be working. I made sure i had the proper syntax in the Steam launcher options by removing the line about horse camera no center, and observed it doing the auto centering. Then re-added it and no auto-recenter . . .

So it seems to be something specific to those two lines.