Cure for Antonia's husband. Bug or poorly scripted quest?

No idea if this is a bug or a poorly scripted quest

You speak to Antonia about her still sick husband and you have the chance to heal him by giving Antonia a potion or visiting directly her sick husband. Here the dialogue options when you first approach Antonia

I have all potions in my inventory but i can choose only one between Bivoj and Bucks Blood. No idea whats the right one. After i gave her one randomly, a quest activates but after a millisecond it disappeares. I checked in the active quests log and in finished quests log and it’s not there. Quest just disappeared.

After speaking to Antonia, if you reach her sick husband you cant speak with him at all because he sleeps 24 hrs long every day. Only way to speak to him is to knock him unconscious then wait for a guard or a vagabond nearby to wake him up.

Once awake, here’ the options you can choose from:

If you examine the husband (i have first aid level 3) it will say that he just needs a potions or whatever. Then the option below reads "i have something for you (give lazarus potion). If you select lazarus among all the potions you have in the inventory and give it to him, then nothing happens. He goes back to sleep.

After reading his dialogue option im more confused than before. Why does it waant Lazarus, if Antonia gave me the chance to choose a potion between Bivoj and Buck’s Blood??? What the hell is the right one?

poorly scripted in my opinion. no real resolution


After a week he changed bed spot. But still sleeping. Dont know if hes been cured or not.

Nevermind. I get over this quest

noticed to same, couldnt do anything to prevent him from dying. sadly he seems to be supposed to die.
would like to see an improvement on this sweet little story

He’s still alive in my game. But still sleeping.

Noticed an entry was added to the “aquarius” quest log, the one i circled in red

If you read up on your potions at the alchemy station the right choice is obvious. Bivoi’s rage will give her energy, but will also (if scripted properly) make her go insane. Buck’s Blood meets her needs precisely. It is a potion to give you energy and lessen your burdens.

1 Like

The potions in your first screenshot are for Antonia and not for her husband, she said that the job is hard and then you can offer her one of these potions.

1 Like

Gave her Bivoj and to him Lazarus. Nevermind the outcome. Hes alive and got journal entry anyway. I already moved on from that quest

Seems like a bug/faulty script to me. Because the UI clearly states “New Quest” but it never showed up in my questlog.
I also tried to give her the potions, but nothing happened.
So I put that quest on the shelf, waiting for 1.42. The patch came, I started the “Aquarius” quest again, but it changed nothing.
But well, I moved on…

Funnily enough, I was never even offered the chance to help Antonia’s husband in any of my three playthroughs (I made sure I had First Aid III before starting Aquarius in my latest playthrough). This is how it goes: I start Aquarius, I talk to Antonia in front of the rathaus, the dialogue is a little confused - it stops after I say it’s no work for a woman, then I start the dialogue again and suddenly she is making references to her husband (who wasn’t mentioned before) and no matter what I do, there is no option to help. I also tried waking up the sleeping villager in the refugee camp, but he only had the general Rattay dialogue options.


The quest goes this way for me too. When talking to antonia for the second time, after bouncing her during the first dialogue, I can ask “How’s your husband?” and she says he’s dying and that’s that. I can’t even offer her a bucks blood potion as others have done to help her carry water. Also, as soon as the quest is over, and I picked the carriers, I find the sleeping NPC who should be her husband dead, and after a day, when going around asking the workers how they are doing, she tells me her husband is dead and my character says he would have liked to have helped more, as if he tried, but he didn’t, because he wasn’t offered a chance!

Also, to be extra precise, I’ve seen people on reddit say the sleeping NPC who should be her husband appears after you take the acquarius quest. For me, he was there since I started the game. I think this quest is still bugged to hell and back!


Exactly same here.

1 Like

Also, I checked the first save made upon waking up at the mill and the husband is already sleeping there… Isn’t there any console command to despawn him and then start aquarius?