D key not working


hello everyone. this is my fırst message on the forum. i tried hard to find an answer for my issue but failed to do so. the problem is that, even for very easy chests, d button is not functioning properly to rotate the lock, despite the sweet spot found and already showed up yellow. so i can’t open up any chests in the game which steers away the fun it’s supposed to give me. is this some kind of bug or am i missing something? (p.s. it is not about lockpicking talent nor instantly breaking lock picks)


Any feedback please?


It doesn’t move at all, or how it looks? Do you have actual version of game (patch 1.7.2)? I heard there are problems with it on consoles or gamepads, but on PC + keyboard it should be fine. You can try to set it on another button instead of “D”.


Playing 1.7.2. and the cursor only moves to find the sweet spot then not moving (rotating) at all. I always play on keyboard . Just want to set it on another button instead of D after your suggestion but D is already assigned to only one thing, which is ‘‘move right’’. Where is the other D in the settings that can be re-assigned for lockpıckıng?


I’m not able to continue the game because of the bug I mentioned. And still no solution on the forum. That’s so sad.


Hi @Seikilos,
I have no solution for you sadly but I this definitely something for the Support Team.
Please get it contact with them: support@kingdomcomerpg.com


Sorry, my bad. There really isn’t lockpicking button in controls options menu. I don’t know what to do, your bug is kinda rare, maybe that’s why nobody answers to this, because nobody has this problem.
I would try to verify files on steam or eventually start new game and check if the bug is still there. If this won’t help, reinstall the game.


All right, thanks for the answers. At least now I know that it is very rare. Will start a new game to check if the issue’s still there. Last solution will be to re-install the game itself.


Ok, tell me if something helped.


55 hours spent so far without opening the chests. Nothing helped but it is ok as it is. I won’t give it up as a history geek.


Oh, sorry to hear that. That’s really really weird thing. I’m not sure if you will be able to finish all quests without opening chests, but hopefully yes. Enjoy the game anyway.


We talked about it a lot. So I feel like I’ve to let you know if it’s fixed. Yes, after giving up my 80 hours of 1st gameplay, it is now fixed with the new playthrough. But I can’t say the bug’s gone forever that I believe the bugs of this game may appear anytime and very randomly.


Good to hear it’s fixed. If it’s working now, I don’t think it will appear again (at least during your actual playthrough). I never had any major bugs, which would be somehow limiting gameplay. Mostly some graphical glitches or weird NPC behaviour, but it’s normal there. New bugs can possibly appear with new patches, I hope it won’t be the case anymore.