Dxgi error device hung / Is there ANY solution?

Hi guys, there seems to be others with this crashing problem, when game totally crashes after short time of playing, and Windows says ‘‘DXGI ERROR DEVICE HUNG…’’. I found many topics in internet, but no solution for me. For some GPU underclocking has worked, not for me. I’ve tried everything i can imagine, and still can’t play this lovely (yet bugish) game :frowning:

Seems to be a problem for random GPU’s, both AMD and Nvidia, not specific models or anything, wich makes this so weird. Not hardware problem because for me and many others all other games work ok, and GPU can take hard stress from stress test’s without problems. I would be ready to play with very low settings even when my GPU should do high jsut fine (RX 570), but right now i can’t play this basically at all.

Things i’ve tried:

  • 4 different GPU drivers from AMD (clean installs)
  • reinstall sound drivers too
  • Both WIN7 and Win10 (so different hard drives with different DX installions etc.)
  • Turned overclocks off and even underclocked GPU
  • Turned settings to lowest
  • And many other things that i can’t even remember now.

IF anyone has solution for this, im still ready to test everything i can. Its sad how great games can be ruined by these unplayable bugs :confused: Its hard to find another just this kind of medieval game.

Hi @Warrington,
First of all this issue can have many reasons. You should also check:

  • Your Power Supply (Watts)
  • Your Mainboard for OC CPU and Memmory. Set all Settings to Defaults.
  • The Connection between GFX Card an Mainboard (PCIe-Lanes) can be checked with gpuz

A DxDaig Log and some screen shots from GpuZ while playing the game could be helpful

Thank you for your response, okay i will check those, and let you know how it works out.

So @Urquhart i got some information. First of all, i tried Rise Of Tomb Raider game, and as i feared based on others experiences, it does the same error with that game. Not as fast as in KCD, but still in ~15 minutes. In KCD it sometimes did it even without starting or continuing game.

Sorry but i don’t have KCD anymorei nstalled on my pc because of limitations of SSD size, but hope that Tomb Raider’s GPUZ log will do(?). Since its almost impossible to take screenshot from GPUz at exact time of crash or just seconds after it, because of the windows freezeng for about 10-15 seconds, so here is attachment of txt file of the log. I took about 10 seconds before the crash, and 5 seconds after. If you need more, im happy to upload.

GPUz log crash.txt (6.8 KB)

Answers to your other questons, i have Corsair CX 650 watts PSU, and other hardware is:

GPU: Sapphire Pulse radeon Rx 570 ITX VERSION (bought it just last week from previous owner, and more than a year left warranty. By the way, this version has for some reason lower memory clock speeds. Sapphire had two versions, and mine is supposed to have 1600mhz (per gb?), but its for some reason 1500 mhz. Anyway i’ve tried also overclock it to 1600 but that didnt solve anything.

MOBO: Asus P8Z68-V LX
RAM: G.Skill Ares 2 x 4gb DDR3 1600
CPU: i5-2500k (auto boost 4,2 ghz) i tried to lower clock to 3,2 so no boost with Intel tool, still crashed
SSD Crucial 240 gb and not close to full of data

And these problems started when i got new GPU, last GPU was pretty old as are the other components (exept PSU and SSD is bough sooner) and with more power hungry Nvidia GTX 560 448core edition i had no problems at all. Ok maybe couple random no error code crashes, but i think that was because of very full and slow HDD wich i also replased at the same time as GPU.

With old GPU i actually played this Kingdom Come about 10 hours, only problem was that it had not enough memory, so had to lower settings a lot and overclock GPU, but no crashing still. Could my MOBO be too old for 2017 year GPU? Im now trying to install some other games and see if i have some problems with more and more games. Obviously i was wrong thinking that its because of this game. Since it happens also in Rise of tomb Raider, problem is probably in my end. If i had more money, i would just replace GPU, but no money so have to solve this with other way.

What @Urquhart did you mean by DxDaig log?

DxDiag. https://support.microsoft.com/en-us/help/4028644/windows-open-and-run-dxdiagexe
Something is strange with your gpu…. https://www.tomshardware.com/reviews/amd-radeon-rx-570-4gb,5028-16.html
80[°C] is too high. Why does the fan won’t go to 100%? Look’s like it’s stuck on 48%. Can you set the fan to 100%?

Thx @Urquhart again for your answer. Here is DxDiag screenshot as attachment. You want some other tab info?

About GPU temperature, i noticed that 80 celsius before too, and i tried earlier, and now again to be sure, i manually controlled fan so it went to 100% under load and temperatures were about 62 c, and still crash on tomb raider, and defenetly would crash even much sooner in kingdom come.

Im starting to think that its either PSU (messed up voltages), GPU or this GPU model has something that my mobo and pci-e port can’t totally handle. Before i RMA the card, im gonna test my pc with my brothers PSU (HX-series so should be great), and if that doesent solve the issue, i guess i could use my GPU at he’s mobo, and see if everything works there.

If these doesen’t solve this, its gotta be software / driver problem. Would it make any sense to test with vmuch older GPU drivers? Like Crimson drivers? AMD doesen’t give em anymore, but there are couple trustfull sites that should share them.

Holy shit, i updated bios on mobo, and now 3 hours playing Kingdom Come and not a single crash, not even when i put much better graphics. Hope it was that original bios, wich apparently had some compatibility issues with newer GPU. I will tomorrow play some more, and i will put some better temp+fan profile to gpu, now that i can see how temps are going in these games.

Thank you Earl for your suggestions! Maybe now i can get that gaming experience that i’ve paid for!

Setting vsync to 60hz helped for me.
Btw why in 1440p and in fullscreen mode setting vsync to 60hz still defaults to 30fps? In borderless mode it works.

Dont know that, did you check if its by default, i mean made like that by KCD? Whats the difference between borderless and full screen anyway? For me borderless doesent scale right, so im forced to use full screen. Changing some AMD settings maybe would solve this.

For me there is still problems with stable fps. Im not getting even stable 50 fps with high - very high, but maybe RX570 with i5 2500k and 8gb ram is not just enough? Maybe i should push gpu and cpu to its limits, since OC is these days so easy and not really risks, unless you go messing too much with voltages.

Anyway, game is now playable for me, and it seems that this game is unbelieavible large and complicated.

I like challenges so i guess next months im playing mostly this. Sorry friends, dont have time for coffee lol. Old nerd in me is waking up, dont know if thats good or bad. And oh, since its weekend, lets try some drunken playing, where both Henry and me are wasted.

I don’t think it’s default. Makes no sense at least. In 1080p full screen vsync 60hz works fine but not in 1440p. I guess in full screen it might run a bit better since it’s not windowed. Windowed and borderless modes can scale to two or more screens. Can’t think of other benefits. In borderless I had to change desktop resolution to match.

50 fps is pretty good for i5-2500k in this game. Had the same cpu before and got only 30 fps.
I have around 500 hours in and some of it has been drunk with Henry time. So cheers and have a nice weekend.

I had this happen to me, and I have a GTX-1080. It turned out to be a very annoying problem with DirectX. Setting the GPU to default worked for a while, but it came back. You can try updating DX… I tried updating it, but was already latest version. I tried SFC /SCANNOW, and there were files that couldn’t be fixed, so reinstalling Win_10 fixed everything. Before resorting to that, try SFC /SCANNOW, try changing PageFile size (switch from system managed to manual, put something like 8GB min / (your memory size) for max. If you’re using a gamepad, try uninstalling it’s driver and reinstall… but this is potentially a DX problem… so maybe try without the gamepad to eliminate it as a problem. Maybe try disconnecting the keyboard / any other additional keyboards / mice while the game is running and see if the problem comes back (if you’re using a gamepad). If your gamepad is connected with BT, unpair and repair. Sorry you’re having this issue, I hope you can get it resolved.

1 Like

As i earlier wrote i found a solition by updating motherboard bios, but now after ~ 15 hours of playing i’ve still had this error couple times, and once my whole pc crashed. Also im not getting even stable 50 fps with high settings. My psu fan has started making noise from fan so im thinking this psu can be unstable. I will start looking for better psu. Made mistake by buying shitty model from Corsair. Never again.

I fussed with borderless / 1440p on a 4k TV, too, and I found that using borderless / 1440p would work if I started the game, the game would be much smaller than the screen, but once you get to the title menu, Alt+Enter to make it fullscreen. This works every time. Borderless still is wonky since you can’t get the mouse over to a second monitor like most other games. Those DX errors seem to happen more on OCd GPUs, this is why I set my GTX-1080 to default when I play this game. I have HD packs and settings at least on high, and just barely get 60 fps, and like 52-56 with a reshade mod using 3 options. I have an 1800x (4 GHz p-state), C6H with 64 GB of RAM and playing the game from a hard drive with tiered storage… 45 GB of RAM and a 256 GB SSD. I never see the mech drive used any more. This is as good as the game can possible run without getting a more expensive GPU. Before the last update, it didn’t even run this good.

Don’t forget the chipset drivers. It’s always good to update them when you do a BIOS upgrade. The chipset drivers are best installed before the other equipment, but when you’re just upgrading… yeah. I’d do the chipset drivers, then do a clean install on the GPU. Actually, you have an AMD card, so they’re combined. Just do a clean install. Get the chipset drivers and it will also install GPU drivers at the same time. GPU drivers won’t give you chipset drivers, though, so look up chipset driver for your MOBO. AMD also offers a “clean install” tool that thoroughly removes all of the GPU driver. Maybe you could use that before installing the chipset / GPU driver. Good luck.