Endless Loading Screen after trebuchet test PS4

Hi,

I play the Royal Edition of KC:D on PS4. I have installed the newest Patch.

I allways get stucked in a endless loading screen right after the cutscene where the trebuchet get tested.

Has anybody a solution or workaround?

1 Like

Try to load an older save file.

Tried this already, didn’t worked for me.

This isn’t possible, because my savegame is only campatible with the current patch.

1 Like

I’m having the same issue and I’m on xbox one and have the royal edition as well. I also had the problem on the patch version before 1.91 and since this latest patch 1.91 came out no change and I’ve tried going to my older saves and replaying everything to see if it changes it and it doesnt. I’ve no replayed huge chunks of the game 3 different times to try to fix it and nothing fixes it. The email I got in response from warhorse before this latest patch told me to wait for the patch cus it was coming out “very very soon” and would fix the issue. So much for that. Please let me know of you figure out a way to get around it since the game is broken at this point since we cant complete the main story.

I’ll test tomorrow or this weekend. I’ll update KCD and see what happens.

Tryed it yesterday with the new patch, but nothing changed. I play the game on hardcore mode and its my second playthroug. On my first run in normal mode i had no problems. Wich mode are you playing?

In the patchnodes there is the point: " Fixed the black screen with UI prompts after finishing Theresa’s story." for the A Woman’s Lot DLC. This sounds exactly like our problem, just in an other part of the game.

I wrote the support about the bug, perhaps you schud do the same, than they perhaps fix it in the next patch.

I’m playing on normal mode. Also I’ve posted on other forums and I’ve emailed their support people multiple times and talked with someone a few times through email about it but they dont really tell me anything. Told me to wait for this last patch saying it would fix it and it didnt. Then when I told them about that they said sorry for the inconvenience and that they’re working on it.