[Fixed] The Amorous Adventures of Bold Sir Hans questline won't start

#1

So when I started the epilogue quest I rode down to the edge of the map with Sir Hans. Here when I talked to him I couldn’t end the game (but I understand this is on purpose) but instead, he starts talking about this girl. Then when he finishes talking I get an objective that tells me to find his necklace. The thing is that even though I get the objective, I still don’t get the quest.
When I try to talk to Hans, there is no option to talk.

So what I’ve tried is:
Replayed an old save
Restart the game (of course)
Uninstalled all mods
I’ve gone to the place where you can find his necklace but there is nothing there
Tried to talk to the dude at the Ledetcko inn but there is no option for this.
Then finally I even tried to replay the whole game from the beginning and not even that worked. I ended up in the same situation.

I just want to play the DLC please help me.

I also have all the DLCs bought and activated.

#2

I’m somewhat confused, you say you go to the inn, I’m guessing the ledetcko inn, and trying to get the necklace back there, but that’s not how you get the necklace back. You have too talk the the dice player in ledetcko to advance the questline.

#3

Alright fair enough i understand that but the thing is that i still haven’t even gotten the quest so there is nothing i can do.

I only have the Epilogue main quest but i can’t start the DLC questline

#4

Thank you for replying btw. right now im going to sleep because its too late here but tomorrow i will post some screenshots to maybe explain a little better.

#5


As you can see this is where I should be able to start the quest.


He starts talking about Karolina


I accept the quest


I get the objective


But the quest doesn’t start…


As you can see i have all the DLCs installed and activated.

#6

Hello, please contact us viasupport@kingdomcomerpg.com with your savegame attached. You probably corrupted your savegame with mods and now the quest is not able to start properly. We would like to investigate anyway.

Cheers

#7

I have now sent you the savegame file

Thank you for replying

#8

Ok so i don’t know why i didn’t even try this but i just reinstalled the game and now it works :slight_smile:
Maybe next time i will reinstall a game before replaying the whole story :smiley:

Thank you Warhorse for this amazing game!
Also thank you @WH_janrucker for your help!

1 Like