Flickering shadows, no fix?

Hi,

I have flickering shadows in dark areas, especially in houses. I’m sure that this flickering is new, in the past I didn’t noticed such problems. By turning the shadow quality down, it gets even worse.

e_ShadowsMaxTexRes=4096 is making this problem worse noticible, but it doesn’t fix it.

What can I do, could reinstalling the game be a fix? Could some graphics card settings cause the problem?

Hardware: GTX 1070, i7 6700K

May help you out.

Sadly it doesn’t fix the problem.

I made a video, the first on standard graphics settings with these weird flickering rectangular shadows.

and the second on ultra or high settings, where shadows are flickering completely:

is there no fix?

Well I misunderstood what you where saying on shadow flickering.In the video I showed was shadow flickering the way I understood it or what I thought you meant.

I do see the weird stuff going on in the videos.I would have to reinstall KDC to help out,maybe someone else knows.I do not know for sure why it it like that.

EDIT:I do know what will fix it and it maybe acceptable to you with hugh FPS boost.Set below to this value -0.01

e_ShadowsCastViewDistRatioLights = -0.01

If shadow poping to close on small objects or other side of room, increase to higher number until happy with distance
View distance ratio for shadow maps casting for light sources,Higher number more shadow in distance lower FPS.
Set Postive for Darker shadows at night,but lose some lights.
Set -0.01 to turn on extra lights on like blacksmith fires Gives about 5 -40FPS Boost ,will diminish shadows and turn some off  at night most noticeable.