Game keeps crashing

Hi,

I’m having a problem with the game crashing constantly. I started a new playthrough which ran OK, textures were popping in and characters were missing heads and proper equipment at times but no serious problem. I got past the Ginger in a Pickle quest and had been hanging around Rattay training combat and various skills etc. At this point I think I’ve logged around 24hrs in my latest game save, it may be a bit longer but I can’t check easily as it crashes so often now!

Last week I had the first crash and didn’t think too much of it, but the next day I had a few more and they have become more and more regular until the game is virtually unplayable. It seems like every time I try to load a save and play a bit it began crashing quicker and quicker and now I’m at the point it will most often crash on the main menu screen.

I have uninstalled mods (I installed a mod to try and improve the textures popping in and missing heads etc), I’ve verified game files and uninstalled then reinstalled the game but nothing seems to have helped. If anything it’s gotten worse since I did a fresh install as I used to be able to load my save and play around 5 minutes before it would crash, now I’m lucky to get a few seconds in the main menu screen.

I’ve searched the forum and I’ve seen some talk of similar problems people are having but I’ve not found a concrete solution. Someone mentioned limiting threads on CPUs might help but to be honest I’m not sure how to do that, I’m not computer literate enough lol. If someone could point me to where I can find out how to do that I’d appreciate it.

With the earlier crashes I had a couple of BSODs, one time the screen just went a strange greenish colour, and the rest of the time the system would just freeze, the games sound would seize up and make a horrible “brrrrrttt” kind of noise and it would then need a hard reset to recover. The last couple of times since I reinstalled however, I’ve started the game and it has crashed to desktop and given me the following error messages in a pop up window:

“DXGI_ERROR_DEVICE_RESET”

Or alternatively I’ve had:
“DXGI_ERROR_DEVICE_HUNG”

As well as this I simultaneously get a pop up from windows at my task bar which says:

“Display driver stopped responding and has recovered.
Display driver NVIDIA Windows Kernel Mode Driver, Version 441.12 stopped responding and successfully recovered.”

These messages seem to suggest to me it’s a problem related to my GPU as opposed to a problem with my CPU and this multiple threads issue, but I may be wrong. As I said, I’m no expert.

My system is getting a little old now, I bought most of the components around 2011-2012, the specs are as follows:

OS: Windows 7 Ultimate 64bit
CPU: Intel core i5-2500k
MOBO: Gigabyte Z68X-UD7-B3
RAM: 16GB DDR3
GPU: GeForce GTX 1080
Storage: 111GB SSD, 1.5TB HDD
PSU: Bequiet! Dark Power Pro 850W

Game Version: 1.9.3-404-501

As I said the system is an older one but it actually ran the game fine when it first came out. I played it all the way past Pribyslawitz and was in Sasau when I gave up my first play through not long after release on this system. Funnily enough that was on a older GPU, an MSI Frozr GTX 560 I believe. Either way the game ran better and with no crashes that I can recall nearer release than it does now.

I can’t remember the makes and models of my SSD and HDD but I’m fairly sure they aren’t the problem. The game is installed to the HDD as I didn’t have space on the SSD :frowning:

I had Win10 but went back to win7 as Win10 was having problems detecting my HDD.

If there is any other info you might need let me know and I will provide it as best I can. If anyone can suggest what may be wrong I’d appreciate it, Thanks!

I’d suggest sticking with w10 and a clean installation. Install the latest drivers and bios from Gigabyte to your mobo. Makes no sense that w10 does not recognise your hdd. Try setting vsync to 30 and if it works without crashing the try 60.

Oh oh. When I got “display driver stopped resonding” error, it meant my GPU was dying. Had to buy a new one.
You should definately look into it.

Thanks for the replies guys.

Yeah, w10 was a real problem for me. Spent ages trying to sort the problem but never found a solution so w7 was the easiest way forward. I seem to remember other people having similar problems with their HDD when I googled it but not sure if there was ever a fix for it after I gave up lol.

Funnily enough I was planning on spending a fair amount on a new system in the new year, new MOBO, new GPU, new CPU etc. I was worried the GPU might be on its last legs, although it’s the newest component in the system. It seems OK when running other games though. Anyway, I think I’ll wait and just build the new rig and hopefully things will run OK then. Just hope I can continue my save, the thought of grinding herbalism again makes me feel ill…

Cheers guys, hopefully I can get it sorted soon. If I have similar problems in the new year with a new rig I’ll be back and will start a new thread.

This game will strain it a lot more than other games, which is why it happens more with it. Not only that your CPU is pretty weak for this game, like on the minimun requirements end. This game is more CPU intensive so that could be another factor into your crashing.

I had those ‘‘DXGI_ERROR_DEVICE…’’ problems too, and updating motherboard BIOS to newest worked for me. I had different motherboard tho. I had same error with another game too, so its not just KCD’s problem. Strange problem, can’t really say its allways bios or mobo problem, because for some people underclocking GPU has been solution.

Anyway, hope you get KCD working. Despite many bugs and problems, this is an absolute masterpiece of gaming world. Can’t really find any games like this. Im starting KCD soon again, with hardened difficulty (also known as pain in the ass mod i’ve heard). Hopefully when i finnish it, KCD2 will be coming out.

E: And i have i5-2500k too, and its defenetly not optimal for KCD, but it will handle the game okay. Even tho this is an CPU hungry game, it depends a lot of GPU, so i5-2500k won’t be total bottleneck, atleast when you overclock it to ~4,2ghz.