Hans Capon DLC Charlatan Quest Bugged?

At one point in the “Amorous Adventure” questline, Hans Capon asks for a potion called “xxx Infinite Allure”. The quest marker points to Ledetchko and the NPC asks 2k grochens and also says to brew it if i do a task for him. Except there is no dialogue for that task. I am forced to buy the recipe to progress further.

Is this a bug? Or there is another way to make the quest appear.

Also note than after the DLC questline ends, there is a “golden star marker” on charlatan which points to a quest, except there isn’t any.

2 Likes

i have heard it is completely bugged
the way to start the quest is to refuse to buy the potion, then he gives you a sidequest which if you complete he will give you the recipe
but like i said, its bugged to fuck

I have the same problem. I can only buy mixture. Charlatan also not work in the last update 1.6 and other, because I wanted to do quest in story mode (activity in Sasau) and i couldnt do it. He is marked star, but there is no dialogue for the quest.
in the new DLC there is a dialogue but there is no quest for Ledethko…
Are you having a problem solution?

It is a bug, Warhorse is allegedly working on fixing patch.
After the fix, thee will start a new quest at Charlatan which will make the whole DLC content available.

Yeah, same here.

to progress the quest just kill him in town. take the recipe. then either run away or go to jail. I chose jail cause pribyslavitz is banking hella money and it’s the quickest way to progress the days to farm it up quickly. I could have escaped because no one cared that I killed him. sure someone said something but the guards just kinda ignored me until I stood right in there face. I read the recipe and am now progressing the story. cheers m8

I followed him to ledjuko and he never even acknowledged he owed me anything, so I knocked him out and took everything off of him, including his cool hooded outfit. Then I took him to Old Straw and told him this guy is a bandit.

Hello everyone, I paid the 2000 groschen but nothing happened, I searched about the internet and found the recipe so here is a short video showing how to prepare the potion yourselves and further the quest line.

I did all the huckster quests and did not get it either. So when he set up shop in the other town I just took everything he had.

I tried:
Buying the potion for 4k - still had to fulfil quests - focus not on Hans
Buying the recipe for 2k - still had to fulfil quests - Focus not on Hans
Rolled the game back. bought the recipe but still had to become apprentice/run errands - Focs not on Hans
Killed Charlatan after buying Musky recipe - Focus not on Hans
Killed Charlatan and then looted recipe - focus not on Hans
Tried killing Hans!
Methinks it’s bugged - guess I’ll haev to concoct the potion witht he recipe