Horse keeps throwing me off for no reason

#1

So, I just bought WH Jenda from Merjohed stables, replacing Al-Buraq. I decked him out with the faceplate armor you can get (in a high nest on a hilltop east of Ledetchko), a caparison, horseshoes, knight spurs, saddlebags. My main reason is that I needed a balanced horse with high carry capacity, and more room to stash my ill-gotten goods. But I do not like his white color.

Anyway, he keeps bucking me off after riding less than a min. I can call him and get back on, no less than a min later he throws me again. He did not do this when I first bought him a few days ago. When he throws me he is not out of stamina, I’m not being chased, we are not near enemies/being attacked, and weather is good. I am also not riding in very rough terrain, I get thrown even on flat terrain or on a trail. I don’t push my horses hard, except loading them up with as much weight as they can handle. I like to take it slow and enjoy the scenery/visuals, so I can be on the lookout for new stuff. I like to prowl, always looking to rob something.

My other horses didn’t do this, my horsemanship is 16. I only have 2 mods (Ultimate Saving), the other is an ENB. Game is up to date (1.8.2) and all DLC is installed, including the high textures/sounds/voices. Game is bought from GOG, not Steam.

Any ideas?

Edit:
I don’t think my specs are playing a factor, but here they are:
Sager NP9876/Clevo P870KM1-G
Windows 10 Enterprise 1607 LTSB x64
i7-7700K
64GB RAM
NVIDIA GTX 1080
Resolution: 2560x1440, all settings on very high, motion blur and antialiasing disabled
FPS averages 50 to 60 in most areas, even with the ENB active

#2

Very strange what happens with your horse.
Which horse related perks are you using? Maybe it has something to do with that, but im just guessing.

#3

@ShadowFox: I posted wrong, faulty memory or w/e. My horsemanship is 18, not 16.
Perks:
Heavy duty pony
Strong thighs
Rider on the storm
Knight
Jockey

If I steal a horse (which I never do, but just to test), I am not thrown. That is the only way I can test without buying another. Can Henry own multiple horses?

#4

No unfortunately not but its a big wish from the community.

Your perks seem fine so that shouldnt be a problem maybe except for Rider on the storm.
Maybe its because you are too smelly and dirty :wink:
What about using no mods?

#5

@ShadowFox: I doubt rider on the storm has anything to do with it, he throws me regardless of whether it’s calm or stormy. Is that perk known to be bugged?

And besides that, its’ description is:
“Horse will be extremely skittish in storms, but will shy less in any other weather.”

I don’t think animals care about how dirty you are, but I’ll try a bathhouse and repaired armor/weapons, then try to ride immediately. In KCD I rarely visit bathhouses or use troughs. I’ll also try without the mods. strange that it’s only happening with Jenda but not others.

#6

ENB mod, and Rider on the Storm perk. What could possibly go wrong?

The first thing you should do with any unusual bug is remove all mods and add them back one at a time to see if they’re the cause. RotS is a pretty useless perk. Don’t take it. It might also be related to Jenda having 20 courage.

#7

@Aradiel: Do you even use ENBs? They only mess with visual effects, not game behavior. If you’re having a bug in any game and an ENB is also installed, the chances are near zero that the ENB is causing it. I have been using them for years in many game and never had any serious issues other than higher resource usage. This is most likely caused by another mod or a bug in the game. Ultimate Saving is also installed, it only changes saving behavior. I have been using it for a year and had no weird issues with it. I’m a fan of the Elder Scrolls style of saving, whenever, whereever, even if it’s during a fight. I hate the Schnapps way of saving. But on the other hand, I try not to abuse saving by save-scumming. I like to just do something and accept the consequences or rewards of my actions, whether good or bad. I would agree that ROTS could be playing a factor, I only chose it because the other perks in the horsemanship category didn’t look that great either.

I did do some tests with all mods removing, just the bone stock game with DLC installed and…same behavior. I backed up and removed all saves that were before I bought Jenda (most of them). My saves folder is pretty big, and I knew the stock game without the save mod wouldn’t be able to handle them all, so I pruned the save folder down to the 10 most recent saves.

@ShadowFox: I went on a visit to the bathhouse, paid for the works (sex, laundry, bath), then immediately equipped my armor set that I had just paid an armorer to repair. I hopped on the horse and within 2 mins Jenda throws me hard down a hill, causing bleeding and near death. I can continue to call him and get back on, but am always thrown within 1 to 2 mins. So, it has nothing to do with how clean/dirty I am or what I’m wearing. With a stolen horse I can ride across the map and back (just tested), turn myself in and pay the fine, never get thrown. The punishment is no big deal since I have the Infamous perk.

Is there a console command I can use to revoke a perk I have already chosen? If so, will I get the perk point back?

Next I’ll add in both mods one by one, play for a while on each, then see if the results are the same. I’m sure they will be. This is most likely related to Jenda’s courage level. But if it is, why aren’t other players reporting the same issue?

Edit: Inspecting Jenda in the game shows him to have a courage of 17, not 20…and a whopping storage capacity of 200001! Best Horse ever LOL! But I’m sure the storage capacity thing is a glitch/misread.

#8

Why are you so certain it is not mod related? You have no idea what mod authors are changing in the files. By looking at Jenda’s stats I would say it is a mod issue. I have never had any issues with Jenda stat wise or other. If you want to use mods that’s fine, but you use them at your own risk and if they bork your game then thats on you.

#9

@AfLIcTeD: Did you read my last post? I just SAID I had removed all mods and the issue persists. So, logically, if the issue occurs without mods, then it is NOT a mod issue. Plain and simple logic. Which proves my belief that neither the ENB or the save mod are at fault. And, even if the issue returns with the mods, then it doesn’t really matter, because it was there both with and without mods to begin with. I could try going back to a save that was just before I bought Jenda, making sure all mods are removed both during and after the buying process, then testing for up to a few days. If it still happens then the game is at fault. Everyone here knows that KCD is buggy as fuck even without mods. There’s no argument there, anyone that says otherwise hasn’t done their research, and seen the untold numbers of posts by people reporting various issues that are hard to explain.

oh, one more thing, even with my mods removed, Jenda’s storage capacity still reads the same as in my screenshot (which was uploaded after I had put the mods back but after testing). It’s probably just a glitch, I still sometimes get the message that he can’t carry any more when trying to move items. 200001 capacity is a massive amount, it would take quite awhile to hit that capacity. For all intents and purposes it is essentially unlimited, as far as the average player is concerned. But I do engage in quite a bit of theft, I literally steal from everyone I can, murder everyone I can, so I don’t find it hard to fathom that I may be hitting that capacity. There are not enough vendors to buy goods from, either because they are dead or alive but stripped naked and penniless. And my fences, they never have enough money to buy my stuff. So that leaves me with a large surplus of valuable items I can’t sell, and so much money that I can’t spend it all. Between quests, i pretty much go on a rampage around the map. i’m KCD’s equivalent of a serial killer/master thief, the role I choose to play as, with an emphasis on stealth.

#10

Do you even know how mods work? Just because you removed them doesn’t mean it will fix the issues. Mods can get baked into the save game and removing them won’t do anything. Did you remove them properly? Did you verify your files after removing them to be sure there were no altered files left behind? The game isn’t buggy as fuck as I have run into a handful of bugs throughout all of my playthroughs since the game has been released. None of of them have been gamebreaking in any way. I have been reading the forums for a while now and most of these “bugs” end up being the result of mods. Not saying the game doesn’t have bugs, as it does, but no where near as many as what people claim.

#11

@AfLIcTeD: Yes, I know how mods work. And I know that, depending on the game, they can put info in the save. The Elder Scrolls/Fallout games are known for that. try removing a mod and loading up a save that was saved while the mod was installed. You will get a message that the save contains mod info and that it may not work correctly without them.

And I know that correct practice for diagnosing issues is to remove mods when testing. Even if they have embedded info into the save. I just find it unlikely that an ENB and a saves mod would cause a bug ONLY with Jenda. As @Aradiel has pointed out, Jenda has 20 courage, the lowest in the game if I’m not mistaken, and mine is even lower, 17. That’s not even considering the unreal storage capacity amount displayed in my screenshot. There is also the issue of Rider On The Storm maybe playing a factor. We didn’t code the game, so we’ll never know. I sent messages to both mod authors and they have stated that they did not code their mods to change weight capacities or other game behaviors. Obviously, save behavior is modified, to the extent that you can save whereever you want instead of needing schnapps. The ENB is nothing more than visual effects. I do check my modsbefore installing them to see what they contain, oftentimes reading the underlying files to get an idea of what they’re doing. If somethings doesn’t look right, I wont use it.

I think that the best I can do is to remove the mods again, load up a save before buying Jenda, then try my tests again. Those mods were installed since the time I started the game, I am not about to start a new game now. Jenda isn’t the only good horse and even though I have encountered other bugs, none were serious except this one.

And yes, the mods were removed properly, I keep a list/count of what files each mod uses, and which files are stock game files. I also make backup copies of any game files that a mod changes. I even go as far as to do a checksum of the entire game folder’s contents after patching/installation and with no mods, so I can conclusively determine if the files are from a mod or not. If the checksums match the values that they should, then all is official and no mods are present. I veriry the game files with GOG Galaxy as well, I did not buy KCD from steam (clearly stated in the first post).

#12

Have you checked all the horses in the game to see if they are affected too? Seems a bit weird that only Jenda is being affected.
Even if mods were the problem, you would think more than one would be.

#13

I leave all my stuff in the chest of miller Peshek, outside the house in the barn. Peshek then sells it for me a few days later. I go back to the chest and take “my” money.

#14

@ShadowFox: Are you referring to the locked closet outside of Peshek’s house that has a very hard lock, with a chest inside that is also very hard? That is where he keeps his sales inventory/money, steal from that and he has no money and nothing to sell. Pretty much every shop and most traders have such a setup, with one or more very hard chests locked behind a very hard door, that is the giveaway that it is where the vendor keeps his inventory/money. Unfortunately those can’t be picked at levels below 10, but my stealth, lockpicking and pick pocketing are at 20, so no issue there.

I had never thought of putting my stolen goods in his chest so he can sell them, then go back and collect later. I’m sure he does business with other people besides the player, as do other vendors (you can see it happen if you just watch). I have also heard that a particular vendor will have more money if you do business with them often, including fences. Which seems true, when I first started working with Peshek he had maybe 500 or 1k Groshen, now he routinely has over 25K. But it still isn’t enough to sell him a significant portion of my stuff. Selling to other fences helps, still not enough.

I’m pretty tired tonight, long day, tomorrow I will check the other horses. If I remember correctly, they had the expected capacities, with values falling in line within a few #'s of their posted stats (since other things also influence those values slightly, but nothing as high as what I’ve seen with Jenda).

#15

Yes, thats the one.

#16

So, I couldn’t sleep, not as long as this horse bucking BS is going on. I put my mods back, loaded save after save until I found one that didn’t have rider on the storm perk. Which also happened to be right before I bought Jenda. Then i bought Jenda again and…guess what?..I can ride just fine. If I accept the perk and buy him, I get thrown within 5 mins. I’ll play for an hour or 2 just to be sure, but it does appear my mods aren’t at fault after all. The storage capacity does still display abnormally, and courage is still at 20.

#17

Told you so it was the perk :grin::+1:
Im glad for you you fixed it

#18

The reason I was concerned about ENB is the environmental effects. If it affects the way the game determines whether there are storms or not, it could be seeing it as a storm, even if it doesn’t look like one to the player.

17 is the default courage for Jenda, not 20. Although it will be 20 with gear. 20 is the highest possible. There’s obviously something wrong with the weight capacity too.

Anyway, like I said, that’s a terrible perk, so don’t take it.

#19

@ShadowFox: Your tactic with Peshek works, and well! I loaded up his merchant chest with approx 5000 items of stolen loot I can’t unload quickly. Just transferred it from my chest in the house to his. I returned 3 hours later and he is just selling his standard items…but has over 440k groshen…MINE NOW! HOLLA, shoulda bought a better lock, baby! I already had 1.2 mil G, but I’ll take more. It really feels like you’re getting over on the game and disrupting its’ economic system by doing this, clearly the debs don’t want players to do this. But they haven’t patched it, and it’s not cheating. I’m a thief, so why should I care, LOL.

1 Like
#20

@AnonVendetta: yes its a good method to accumelate millions of Groschen. I only used this after i finished the game and started to have some fun with the gamemechanics, like robbing all contesters of the tournament so they all stand in their underwear trying to fight you LOL.