How do I get the bow from "From the Ashes" DLC?


#1

I built the Guardhouse and the Archery Range and I can’t buy the bow from the Archery Master. He has no dialogue to initiate trade. Am I missing a step?


#2

Are you on PC? Do you have any MOC installed?
If yes, try to deinstall the mod / move the MOD folder, and go to the archery master again.

No, the master sells the bow…


#3

I am playing on PC and I have never installed any mods. The only option I have when I speak to him is to start an archery contest.

I tried reloading an earlier save and building the Guardhouse/archery range again, but I still can’t trade with him. Is there a way to just give myself the bow using console commands?


#4

Please make a bugreport to:
support@kingdomcomerpg.com

Thank you!


#5

I bought it from the archery master, so something is wrong. Reported it.


#6

Yes, same here.

Archery Master not selling anything in my new line game building Pribyslavitz


#7

I think the bow was also in a chest. You can probably spawn it in with cheats on PC?


#8

Or use the mod: Capon’s hunting bow, comes in an 80 & 100 Version with 1 str and dex.


#9

I also have this happening, only option is for the archery contest. I lockpicked the two very hard chests in the guardhouse and they were empty.

I tried a few different build orders but didn’t see any difference.


#10

Until fixed. Bug started with 1.7.0 update.

1.7.1 still not fixed.

Not checked lately with 1.7.2, but probably still not fixed


#11

1.7. Hotfix 1.7.2 - November 21th

  • Many crashes occurring during time skip or jail time fixed
  • Crash in The House of God quest fixed2 only fixed 2 bugs that caused game crashes.

#12

I am currently plaing the “From the Ashes” DLC and just built the guardhouse with the archery range. Actually I ran in the same isse as reported here in this thread. I just can start an archery contest at the bow master.

I play on PC, the KCD version is 1.8.2-247i

Is there already a solution for this, or at least a workaround to get that special bow?

Thank in advance!


#13

Dude, I have been begging the Devs for months about this, It was supposed to be resolved this past patch or the next… Im waiting also.