Is there a way to turn off voxel streaming without bugs?


#1

If you turn off the voxel streaming and force the game to revoxelize at runtime the gi looks much better.

However this will break quests AND incorrectly voxelize around buildings. Is this a bug or a limitation that was never addressed?


#2

Just asking do you need the disc,because I can not tell the difference with it off or on in game.
Or can you list the settings/commands you are using.Or do you just restart the game everytime you make a change .
e_svoStreamVoxels = 1

I am just adding this here e_gi =0 but I use these commands with all voxel commands at there defaults.Voxel commands not listed.I have not had any problems with e_svoStreamVoxels = 1 on
e_svoTI_SSAOAmount=1.25
e_svoTI_Apply=1
e_svoTI_DiffuseConeWidth=12
e_svoTI_RsmConeMaxLength=6
e_svoTI_VoxelizeUnderTerrain=0
e_svoTI_GsmCascadeLod=5
e_svoTI_SkyColorMultiplier=-1.0001
e_svoTI_ConeMaxLength = 30
e_svoTI_DiffuseConeWidth = 30
e_svoTI_DiffuseBias=0.05
e_svoTI_SpecularAmplifier=1
e_svoTI_DiffuseAmplifier=1
e_svoTI_Saturation=0.4
e_svoTI_ResScaleBase=0
e_svoTI_LowSpecMode=6
e_svoTI_Diffuse_Cache=0


#3

You need to start the game with e_svoStreamVoxels = 0! it will not work if this value is set at runtime. Then set e_svoTI_ConeMaxLength=64. e_svoTI_LowSpecMode=2 works pretty well for me, but you can use something slower if your gpu is getting hit too hard.

Youll notice that the GI will occur in more of a wider area, and is more accurate to the change in weather as well. The best test scenarios are forests. Also… if you really want to be blown away, e_svoti_integrationmode = 2 Is FULL GI. We are using Integration mode 0, which is very basic 1 bounce diffuse GI. However, the game becomes VERY crashy with this. But when it works, its beatiful… albeit somewhat slow.

Personally, I’d take integration mode 0 and the ability to voxelize on the fly.


#4

Thanks for the tips,tried it out and it looks nice at times but is not very good on some textures,hdr bloom,reflections and is too dark .
I am going to play with the settings and see if I can maybe atleast get it a little better looking.Also add shadows to all objects if possible.
Sorry about not answering your question , I am just an idiot and did not get what you were saying in the first post.


#5

I have come to the conclusion that enabling full Global Illumination just sucks and I see why War Horse did not imperilment full Global Illumination,but I know the graphic guys look at the forums,if you can provide some settings to show how Global Illumination works properly that would be great.
Sorry off topic.


#6

Game looked amazing with full Global Illumination sadly alot crash I feel like game was supposed to look like that+1.25 SSAO, volumetric fog and max settings without motion blur hands down best looking game ever!


#7

Delete for now


#8

Hey Gerrard! I think you might be mistaken. Your Global Illumination shots actually show NO GI. Just direct Lighting, hence why they look very flat and are dark. GI simulates light scatter, so areas with light will accumulate and scatter and areas that light cant reach will taper out more realistically. https://www.flickr.com/photos/135887904@N06/32195621412/in/album-72157675563942263/

I realize the asset density is HIGHER in these shots, but look at the light scatter and the subtle coloring of the ambient light. Notice how it distributes in a more even way. This is from beta. You can get this look from using integration mode 2, which simulates diffuse and specular bounce, but when it works, it does not work for long. Or in the case of your screenshots at all.

Its why I made the post. I find that the game is very glitchy when enabling certain cryengine features and since they seemed to work in the beta phase just wondered if there was a way to turn them back on.


#9

OK you maybe correct,I gave it a shot.Thanks for the advice.