Kings Silver - question

I recently bought a Kingdom Come (during Steam Summer Sale) and I really love this game. Currently, however, I’m stuck on the Kings Silver quest. Is it possible that this quest is still not fixed? I’ve seen posts on the forum about problems with this quest but they were related to previous versions of the game. Maybe I’m doing something wrong? Because I can’t just complete the mine examine goal. Every time I go to the mine (even when I killed Nemoy or Zuzana) there is a cutscene of Nemoy dying and in the journal says that I didn’t do what Fejfar asked for.
Thanks for your help

  • It is possible to make the quest impossible to finish by going directly to the mine shaft, without talking with Nemoy first. All the events will trigger as normally, but finishing the quest will be blocked. Visit all points of interest in their alphabetic order described above to finish the quest fully and discover the truth.

I did all the tasks in alphabetical order, I talked to Nemoy and went to the mine and he’s still dying and I have to run away (which means I didn’t examine the mine as Feyfar asked)

Journal sometimes says wrong things, it’s bug in the journal probably. Nemoy will die everytime, it’s in the scenario. Quest will not fail, go to Fejfar and he will be happy.

Game assets show that it is possible for a journal to show something else:

objective_7616_LogStarted The Master Engineer has sent me to
check the mineshaft, the water works and the ore yard.

objective_7616_LogCompleted I examined the ore roasting plant, the waterworks and the mine gallery, as Master Feyfar asked.

objective_7616_LogFailed I didn’t get round to everything Master Feyfar wanted me to check - I had something more pressing to deal with.

try this:

This quest is so buggy even Bethesda is pointing fingers and laughing.

  1. I accidentally killed the mine watchmen (thinking it was a bandit). bugged my progress for some reason
  2. talked to the foreman who is asleep 23 hours a day (this hasnt been fixed… why?). Conversations went normal, but then it just ended and only the pickpocket optn is there
  3. talked to the widow, she referred me to the foreman, rinse and repeat.
  4. tried entering the mines, got the aforementioned bug too

Then I just gave up. This quest is just a nightmare.

1 Like

You’re right, it is awful

This mission is easy, just check the mines/locations (ore roasting plant, waterworks), talk with the Woman (check your dialogue for better results), then Nemoy.

Nemoy ALWAYS will die killed by his own people when you are checking the mine gallery (failed objective, not the mission). Kill whoever atacks you if you like. Talk with the woman again, she will tell you the truth (check your dialogue options again for better results).

Go back to Fayfar (check your dialogue for a better reward).

Bug? I don’t think so… poor scripting? absolutely.

PD.: Nemoy is a lazy foreman, he just wake up at 10-12’ aprox, everybody else wake up early. He allows to enter the mine galery without a fight with the mine watchman, that’s all.

1 Like