Low Cpu and GPU usage Town 3900x/2080 super

Hi there.
While i’m playing inside town, something is not quite right with my fps. In the same area(place), but different angle i have 30fps difference.
My pc, has a 3900x with 2080Super, all drivers and bios updated. While testing, i’ve noticed that my cpu usage it’s so low and even my gpu usage it’s not max out.
I’m playing with all settings on ultra, lod etc etc… max out, 1440p.

I think, inconstant frame drop in the same area, it’s due to from almost 100% gpu usage to 80%-85%! The graphic card, doesnt even reach max temperatures in town because of the poor usage. Is there any way, to fix this? Or it’s just bugged?

That’s because there are more objects in the second picture. Buildings and NPCs, who all have layered clothing. It’s the NPCs that do it, there isn’t much you can do about it really.

I understand, is more demanding, but why the gpu usage go down, when it’s needed the most?Or why my cpu it’s always 20%-23% usage?

The game is more CPU intensive than GPU. It’s just the way the textures are streamed. If your CPU is not doing it’s job then you need to find ouy why.

  1. Vsync turned on? Maybe switch
  2. Nvidia has control panel. It has a lot of settings like vsync etc. first of all you can run app specifically using nvidia processor if you dont do already, not only that but it has about 20 settings that could help or not help u. it helped me get more fps in some laggy games
  3. if your CPU is high then maybe turn off programs and services like windows search indexing? it runs in the background and uses ton of computer resources, and there are many u could turn off.
    4.get process hacker. task manager often shows ‘wrong’ values and process hacker can show more.
    after u install it u can look what apps take majority of ur cpu, gpu, disk, memory, I/O, internet, etc…
  4. if all fails then you can eventually lower resolution and graphics but thats probably not what you want.
  5. turn off other apps that use GPU
  6. if ram is low then u always can use virtual/paged ram (google it)

Basically, this is due to DX11 and its drawcall limitations. Hopefully Kingdom Come 2 will switch to Vulkan or DX12, in which case the CPU power will be able to be used more effectively.

Look at cpu usage per thread at task manager. Its only one thread to compute those objects and has 100% usage. Its behavior of old engine and optimalization.