Main quest failing in DLC 2

Greetings,
I would lile to ask for help with a bug, that happend to me yesterday and today in DLC 2. Let’s get to it.

What happend?

  • I was playing the main quest in this DLC „Honeyed Words“, where I just completed the subquest „Game of Throws“. I suceed in it, brought the necklace to Hans, sneeked into Karolina’s house and put the necklace and the letter into her chest. After that I waited till the next morning, as I was supposed to. I talked to sir Hans, we finished our conversation and after that the objection to look for the potion of love and quest „Honeyed words“ failed without any reason.

What were my solutions?

  • I tried to restart the PC, the game itself, reload the save and also to restart and replay the whole DLC. I also am using few mods, so I tried to do the quest without them. But with no results.

Where in the main story I am?

  • I’m supposed to talk to master Feyfar about documents from Ulrich (I’ve completed the sidequest from Master Feyfar succesfully).

Charlatan?

  • I’ve already completed the sidequest from Charlatan in Sasau, so he has moved to Ledetchko.

I’ve completed this DLC once in another storyline, shortly after its releasing with no problem. But now I came out of ideas of what to do, so I would be really glad for any help or advice. If not, then at least hope, I’m not the only one here :smiley:. Thanks for any advice.

God be with you lads,

Havran

I believe the Charlatan has a seperate line of quests when he gets to Ledetchko. I dont know that forsure so Id say check the wiki to make sure.
The way the game plays its hard to tell if this is a glitch or simply the mechanics at play but I garuntee you’ll find your answer on Google somewhere.
Let me know what you figure out Im curious