Quest help- questions and answers report to sir radzig at lookout


#1

Hi, so I’ve been having problems with the quest listed above (just after curing the pestillence and bringing the bandit back to rattiz prison. Anyways, my new quest is to report to the lookout point, however he’s not there! Ive been searching for bug fixes online- Ive tried mehorjed camp just to the left of stables, as well as all the castles in rattiz. After much exploration Ive found hes still at neuhof stables, I can talk to him, however when I ask to progress in the main quest he says “not here henry, wait till we get there” its becoming beyond infurating, and would love peoples guidance!! cannot reload and go to an early save as Ive been playing other side quests whilst trying to find sir radzig :’(

thanks! david.


#2

Have you completed the Ginger in a pickle quest?


#3

yes, ginger in a pick is a few quests ago


#4

I have the same problem. I treated the villagers and I took the man to rattay jails. The quest tells me: talk to sir radzig at the Talmberg lookout, but he isn’t here :frowning:

I found radzig in neuhof, but he says the same thing “not here henry, wait till we get there”…
Edit: Thx Morfi :wink:


#5

Hello, its a known bug. You can read through to find out more at >


#6

Hi Morfi, I’m greatful that this helped Magnan, but I still cant find him! as I said im my original post Ive searched rattay and merhojed already and cant find him! the only thing I can think of is can you give a detailed explanation of exactly where he is in merhojed? ive searched the camp to the left on the map, as well as the perimeter of the stable but can’t find him anywhere!


#7

See this thread.


#8

I tried a lot of “solutions” presented on this forum and reddit, but none works :disappointed_relieved:
I spent too much time redoing this damn quest. It’s tiring… I’m giving up and I’m waiting for an update :pensive:


#9

Sorry to hear this. Sir Radzig is suppose to wait for you at lookout near Talmberg, where cutscene triggers afterwards, not in Neuhof or Merhojed. Sadly this quest part has so many different bugs and solutions for people I suggest you to wait for upcoming 1.3 patch, where hopefully it will be fixed :blush: There is also official statement by Community Manager: Known Bugs And Reporting new ones
For me this solution was the only one working (tested it on older save) but I would lost a lot of ingame hours by doing so, I am just waiting for fix now :sunny:


#10

Hey there.
I got exactly the same bug and it is not fixed in 1.3.1
Do you guys got any ideas or infos about this shit?
I also spent a lot of time meanwhile i waited or searched for Radzig, doing side quests or raiding kumans. I don’t want to loose my progress. :-/


#11

This is happening to me now…only I found radzig in pirkstien area. We conversed about everything that had taken place since neuhof, then he sent me to rovna to question the merchant and help the engineer. Then he added Don’t go there’s something I want to talk to you about. I’m so confused. I made a save files before I spoke to him. Haven’t tried a full restart/reload, but it’s next on my to do list.


#12

The latest patch ( whenever it arrives) might fix the quest. It is broken in so many ways atm that it really isn’t possible to advise how to progress. A month ago I had to go back to an old save losing 32 hours progress.


#13

#14