"Rattled" side quest reward bug

Possible Spoilers.


I’ve completed the quest, and have the step “Go and see Zach the blacksmith for your reward”. When I do, I ask him about my reward and he gives me 2 speech options. Asking about Master Ota selling his business and the part about our deal where he tells me about the counterfeiters. However, once I click the part about our deal, it fails the part of the quest “go and see Zach about your reward” and completes the quest Rattled. I never receive a reward.

I have exaxtly the same problem. Will be this problem solved in upcoming 1.3 version?

Have you didn’t wait until he walks back to his workshop?

The “reward” line pops only after he is working with his irons.

Yes. It is not possible to ask for reward before he return back to his workshop.
Here is video of the bug https://youtu.be/SizmBnOzwtg

He gave me 200 Groschen + Vitus cuirass. (But I didn’t steal anything from Master Ota.)

I also didn’t steal anything. I won fight against Ota and then I should go to Zach for reward.
I just updated to patch 1.3 and nothing changed.
So I lost just 200 groschen and some armour? It has no impact on main story?

This is just a side quest.

But it strange, that I already know that Zach is working with copper, but the main quest “All that Glisters” still display to me current objective: “Find out who in Sasau works with copper”. I thought that it will change after complete this side quest, because Zach promises me to say everything about the copper.

I returned back get the information about copper from zach by force instead of agreeing with the faith against ota and the main quest was updated. Finally.

still not fixed in 1.4.1
guess it wasn’t among those mysterious 200+ bug fixes mentioned in the changelog :stuck_out_tongue:

Still not fixed in 1.6 for PS4.

1 Like

Bugs are starting to really fuck me off in this game now

I get the same problem! I didn’t receive any reward, tried a couple of times to reload a save, nothing :frowning:

I recently did this quest again after patch 1.9.1 on the PS4.
When I asked Zack for my reward, the quest checked off but I received nothing, no Vitus cuirass. :disappointed: