Several Problems (Low FPS every few seconds, sound bug, long loading)


#1

Hey, I have several large problems, hope someone can help:

First every 5 seconds I get very low fps, lower than 20, no matter my settings. On the highest (not 4k), I get around 50 fp, totally fine, until every few seconds it goes down to less than 20 for a few seconds, and then after a moment it goes up again. Happens on lowest as well as highest settings.

I have 16 GB Memory and a GTX 1080.

Also every once in a while, the dialogue and cutscenes will have no sound, low textures and occasional freezes. After a while, the sound comes back and no freezes anymore, but I missed a good portion of the dialogue. It doesn’t happen all the time, but more often than I am willing to forgive.

Another problem is that I have very long loading time doing everything. Opening the map, starting dialogue, every time I have to wait 10, 20 seconds.

Something strange, I am using Geforce Experience, which tells me the optimal settings for my games.

Usually, it is pretty accurate. It shows me I can play Assassins Creed Origins at 2K on Very high with some extreme options, and I am sure AC Origin is a pretty demanding game.

However, it shows me for KCD literally the lowest settings for all options, even the Objects distance at 0. Now that can’t be right…

Needless to say, these problems have drained all fun and I don’t want to continue like that. It’s fun when it works, which makes it even more painful.

EDIT: I have made several Videos that show the Freezing Bug that makes the game unplayable for me. These kind of freezes happen every minute or so. See the playlist here:


Full Release Preformance Issues
Very, very low performance
#2

Have you updated your drivers i have a 1060 and will see what its like when im home.

If you have maybe try downgrading them etc


#3

Obviously I already have the newest driver.

And what do you mean with downgrading them? The driver? Doubt that’ll help, since the newest driver is specifically for KCD.


#4

Sometimes newer drivers can be crap. Its always worth testing ill be hlme in 6 hours or so


#5

Yeah, normally, but again, sicne the newest driver was specifically for this game, it would be very starnge if that was the cause.

Also I still wonder what is up with Geforce Experience showing me the optimal setting being everything at it’s lowest, when it does that for no other game. Something can’t be right there.


#6

Hello there, I have some weird fps issues as well. I’ve tried all settings from Medium to Ultra High no difference. My setup will be pasted down below. Also I have random screen freezes for about 5-15 secs. I was also bugged and was walking in mid air, once I got knocked off my horse. My GEForce Experience sets my setings at very high, but the game is abit unplayable at these settings.
GPU: GeForce GTX 1070
CPU: Intel® Core™ i5-6600K CPU @ 3.50GHz
Memory: 16 GB RAM (15.92 GB RAM usable)
Current resolution: 1920 x 1200, 59Hz
Operating system: Microsoft Windows 10 Home


#7

I have a better card, yet my Geforce Experience shows me the lowest setting, while you very high? Something is not right here.

But yeah, have similar problems.


#8

Okay, now I have another problem, the game keeps freezing all the time, often when I enter a new area, get hit, or something else happens, always for about 10-20 seconds.

That together with my other problems literally make the game unplayable to me. The excitement I had is more and more turning into frustration…


#9

I have the same freezes mate. I sure hope they patch it soon. It’s hard to look past these things, but if you do…the game is fantastic.


#10

Exactly that is the problem!

The very, very few times the problems are not that big, it’s so much fun! But it has become unplayable for me, no matter what settings I use…


#11

I agree, with the fps drops and the freezes combat is a pain the ass.


#12

i am experiencing the random stuttering(i cannot determine what causes it) and the sound bug where dialog fades out in cutscenes. but the rest of the game is well polished and smooth


#13

Since leaving Rattay, it has gotten much worse. Now the freezes happen every minute or two, usually for up to one minute, and the sound bug happens almost every dialogue, causing all sorts of bugs along the way.

Right now, the game is unplayable for me.


#14

Similar problems here: FPS in the hundreds for 5-20 seconds at any settings, then it freezes for 1 second or so then it goes again up. Same goes for the sound. My GEForce Experience sets my setings at very high. Drivers are updated to the latest version as well as the OS.

GPU: GeForce GTX 1070 8GB
CPU: Intel® Core™ i7-7700HQ CPU @ 2.80GHz
Memory: 16 GB RAM (15.9 GB RAM usable)
HDD: 256GB SSD (88.5 GB free after installaion)
Current resolution: 1920 x 1200, 59Hz
Operating system: Microsoft Windows 10 Home


#15

I solved the stuttering problem by reinstalling the nvidia drivers, then rebooting the PC.
The game is now very smooth.


#16

Nevermind the low fps…

The game has become unplayable. The freezing and sound bug have become way worse. Every 20 second the sound suddenly starts looping and afterwards the game freezes for about 1 minute. In one cutscene, it happened 4 times (!!!) !

Strangely, when the game freezes, my hard drive makes a short sound a few second after the freeze and a few seconds before the freeze stops.


#17

Having the exact problem, even in dialogues. My game hard drive seems to shut down during the freezes and then reboot after a few seconds. The game ist installed on a “Samsung HD103SJ ATA Device” while my os is installed on a ssd. The freeze occures, no matter the set graphic options. Update of Nvidia graphics driver didn’t solve the freezes. Game is unplayable.


#18

Same freezes-problem here. Constant freezes of 5 seconds or more, especially in villages. Settings don’t play any role. With those freezes the game becomes unplayable …


#19

5 Seconds? Be glad, the shortest I get are still more than a minute long…


#20

Accidental double posting