[SOLVED] 15-25 FPS on 1080ti i7 4790k - Any ideas?


#1

Just bought this game on steam and I’d love to give it a whirl, however for some inexplicable reason the performance is ridiculously bad. I’m running a 1440p 144Hz monitor, GTX 1080ti, i7 4790k and 16GB of RAM, yet I’m struggling to get even 20 FPS on medium settings. Any suggestions of what key thing I’m missing here, or does this game just run awfully for everyone?


#2

Hi @Vanir112 Can you post a gpuz screenshot with the sensor tab while the game is running?


#3

Alright, so firsttly I just want to say thank you as you’ve indirectly solved some serious issues I’ve been having with my PC for the last 5 months.

In the process of loading up GPU-Z to get that screenshot for you, I noticed the GPU was registering via PCI-E 3.0 1x. Due to the peculiar chassis I’m using I have to use a PCI-E riser to connect my GPU, and it turned out that the riser was faulty and speed limiting the connection down from 16x to 1x speeds.

I’ve taken out the riser and tested the GPU directly connected into the slot where it’s now working perfectly. I’m now able to run ultra settings around 50fps, although I’ll be using Very High instead for stability and higher framerates.

My framerates in every game I’ve tested have at least doubled, with certain games like KC:D and the more recent Assassin’s Creed games becoming playable after having similarly crippled performance.

So yeah, just wanted to say thanks for inadvertendly exposing the problem to me!


#4

Disable V-Sync and 2×TXAA


#5