Solved! Very Low FPS on new i9 9900K + RTX2080 + 32GB RAM + SSD

Ended up being the Windows 10 itself that was the culprit, it was coming with strange high CPU usage on random programs in the background.
A clean re-install of Win 10 solved this problem.

We are talking 35 fps on start menu and 15-20 fps inside the game at starting point.
My old rig was 2500k @4,5 Ghz + GTX 580 OCed and that ran this game @ 30+fps with little lag on medium.
Finished most of the game on this.

New PC it’s just serous lag and low fps, completely unplayable.

GPU-Z is showing x16 v3 when game runs.
MSI afterburner logs show the GPU never goes above 24% usage (when trying other games or 3d-mark it can go up to 93%)
CPU usage is V-high on 5-6 Cores.
Tried all the advice I can find online, all the settings, GFX mods, limiting to certain cores, -2% on cores and other stuff.
The system is OCed, have tried putting everything on stock and nothing changes.

System is:
i9 9900k @ 5Ghz
RTX2080 8GB Gigabyte clock@ 1808Mhz, memory @ 1750Mhz
32 GB gskill @ 3200 (haven’t bothered to OC the memory yet)
Game is on SSD.

Any helpful insight is welcome.


Please try Setting the Memory Clock to stock Settings. Are you on single or dual channel mode? Are you playing on 1440p?
It could help to know your Mainboard type.

Have you other processes running in the background?
Also disable Vsync that cost a lot fps!

MB: Asus Strix Z390 -E Gaming.
Gaming on 1920x1080p @ 60hz
Memory is dual channel and memtested, is on XMB II.
And has been tried at stock speed.

Thanks for reply.

It’s a fresh Win10 install and I always remove all unnecessary from startup/background.
Background is around than CPU 7% & 13% Mem use before game start (with chrome open).
V-sync on or off, there is no difference.

Thanks for reply.

Hi there.
It might be an issue where the game runs on CPU integrated graphic card.
Try this way:
Or this way: Open nVidia panel, go to Manage 3D Settings and Program Settings, choose KCD and set run with nVidia card

Can you post a gpuz schreenshot. I mean the Sensors tab. While running the game!

I was getting good performance on a 1080 Ti with a 9900K. I reckon something more fundamental is wrong - what’s your GPU usage showing?

Max 28% around the main menu and then dropping to 9-10% once in the game.

Win10 default was RTX 2080, but did choose the high performance option. Nothing changed :frowning:
Nvidia panel has no option of choosing between IGU and RTX2080.

Is this while playing the game??? Looking quite static……

Here is a screen shot with GPU-Z and MSI afterburner sensor log on and cleared for the game just now.
This is with default GFX set on V-High ingame.

for unknown reason your gpu is not changing values correctly.
your Memory load should grow by time…
Fan Speed should correspond to Gpu load and temp.
Everthing look like it’s frozen or static set……
Are you using any other OC Tools???

Just BIOS OC on the mem and CPU, MSI Afterburner for GPU.

Whent back and loaded optamized defaulfts in bios and shut down GPU OC and nothing changed.
All usage is still very low on mem and core, but if I load up Yakuza 0 I get 73% usage and everything is changing values.

Task manager shows that KDC is using RTX 2080.

just so weird.

I suggest to open your Rack and recheck all Powercables to you GPU.

Just launched shadow of the tomb raider and with everything maxed there I’m getting 80+fps, gpu on 90% 5GB V-ram used and power usage upto 200W on GPU.

It’s like it’s just this game, yesterday I removed the card from the pc and reseated and connected power cables again. Just to make sure that it wasn’t badly seated (for the 5th time).

Have you installed your Win10 on AHCI mode SSD? And on UEFI bios? And put your monitor cable into the graphics card HDMI/DP slot? Try to disable iGPU in the bios so that the game will definitely use your RTX 2080.

It’s not the game. I have i7-4770, 16 GB DDR3, RTX 2070 and playing smooth in 3840x2160 (4K), Details on Ultra/Very High.

But hey, maybe it’s the game. Could it be that the game has problems on CPUs that have more than 6 cores/12 threads so that it runs on virtual cores instead of real cores? Disable HyperThreading in the bios to test this.

rtx 2070 4K ultra/very high smooth I dont think so

You can think what you want. I know how the game runs.