Still getting random frame freezes

Ryzen 7 3700x
Powercolor RX 5700 XT Red Dragon
32GB 2800mhz RAM
2tb Samsung Evo SSD NVME M.2
750w PSU
Plenty of cooling with fans and Corsair AIO

“I have used custom user configs
sys_main_CPU = 0
sys_physics_CPU = 2
sys_streaming_CPU = 4
– Disables motion blur, yay
r_MotionBlur = 0
– Disables Sharpening for minor FPS Gain
r_Sharpening = 0
– Modify this accordingly based on how much RAM you want to give the game
r_TexturesStreamPoolSize = 4096
e_ShadowsPoolSize = 2048”

I have used the BES mod for limiting CPU useage by 2% as recommended
I have toggled affinity in processes
I have tried multiple drivers both optional and WHQL all current for Radeon
I don’t know what else to do. This is infuriating and I hope to god Warhorse that you learn how to optimize for multicore CPUs PROPERLY in your next game or it will not sell as well as this one did.

Im running 1080p MEDIUM settings Full Screen

KCD needs a lot of CPU, reducing the CPU usage is the wrong way ^^
Have u set your energy options to High Performance? Helped me a lot

I have and Ill try removing all the limiter options and mods. Maybe Windows reset the power settings during one of the many mandatory updates. Ill also run Ryzen Master and make sure its set to game mode

A 3700x should be more than enough for this since it handles Cyberpunk so well.