Stuck in Combat


#1

So on the scouting mission to Pribyslavitz,I was seen while leaving and decided to run/ride all the way back to Sir Robard’s camp, however upon arriving I couldn’t sleep or wait as it says that I’m still in combat, I’ve waited long enough and the enemies are not following me. I can’t save or anything. Any suggestions?


#2

well i talked to Sir Robart and the game crashed… nvm


#3

I also did the same but as I would ride with my horse I would wait till there were one or two behind me and I would fight them off and again and again. I killed about 5 and they had about 3 more and then my game crashed, the second time I ran got to sir Robert and started the mission and as soon as we get the Pribyslavitz the game crashed 6 times… ARRGGG, im about to ripe the screen off my laptop if I have to see one more crash. and ohh yeah for some reason I cannot sleep either because it says im in combat, with so many crashes and bugs this should of been a free sample and let the community help fix this game because I spent 70 on this game to play 5 minutes and crash.


#4

yeah I finally got through the combat and after I haven’t been able to start the actual battle, I’ve tried on 2 different computers, IDK whats going on I’m crashing over and over as soon as we decide which route into the camp to take.


#5

You have to get to the battle without loading a prior save.


#6

I tried that all it did was crash even before I can get to sir Robert


#7

I hope, I’ve reported it already, but this can happen any time you are in combat and symptoms are different

  • You can’t sleep cause you are in combat (happened when cuman above woodcutter’s camp escaped to bushes)
  • Neverending combat music (happened when I killed annoying soldier in tavern)
  • (you can’t sleep without reason given) (happened like 3 times and I dont think is clearly related to previous combats or it’s load bug)

#8

well I can sleep anytime but if I go to Pribyslavitz well I cant and also game just crashes every time the scene loads with sir Robert asking which way is the safest to attack Pribyslavitz. really annoying, well hope they fix this asap because I really want to see how this combat will take hold.


#9

If you don’t kill enemies that you have fought or have spotted you then you are out of luck my friend. I guess Warhorse hasn’t added the feature yet that when you out run them then you are no longer in combat.


#10

Battle of Pribislavitz is bugged.
But if you really want to play it, there is one way.
Only time the battle does not crash is when you play it in one go without loading.
But I warn you, even if you get there the performance is really bad and you be glad for 10 fps.


#11

the battle of pribislavitz bug is kind of huge I guess; also not being able to sleep (still being in fight mode) should be worked on. Is there any chance there will be a bug fix update soon? I havent had time last months to follow the forum.


#12

It’s being worked on. I know save state is one of the priorities WH has mentioned for the first patch.


#13

Are there any updates on a solution for being stuck in combat?


#14

It has been 2 years and this bug hasnt been fixed… ARE YOU FUCKING KIDDING ME WARHORSE ??? Even in the full release of the game ??? What is fucking wrong with you…


#15

They cared more about money it seems than releasing a playable game.


#16

I agree, I am a programmer and bugs like this can be fixer quite easy, just a matter of a simple check… I bet if they spent less buying off youtubers and more on programmers the people who will end up giving them money will be way more satisfied… but who cares if we are satisfied, the important thing is to push off a game worth 5 times less to as much people as possible… “Boo-Hoo, don’t buy our game from sites that sell keys cheaper” We will do it, when the game is not worth what you are asking for it… this should have been a 20 euro game… not a one that costs almost as much as Grand Theft Auto 5, when it cost the studio 260 million dollars less to make it… But I guess it was a good stratedy to buy off youtubers who cut the buggy parts of the game off their videos…


#17

Ehh really a full release game can have this kind of issue. My last few saves are now broken from cuman clearing quest north of Talmberg.

Why not implement a time checker for combat state or some some backup combat clearer at monastery or inn. Its a singleplayer game anyway it should be more important to allow players play the game than to protect potential glitching from any way to end combat if really needed.

Come on this game feels like a beta test it’s a really good game, but I would have waited for a full release if I had known.

I really hope you are working on this stuff. I’d like to see more this kind of games in the future, but I can’t recommend this to my friends with a straight face.


#18

I was just stuck in combat. I managed to snap out of it by hitting a guard and accepting jail time.

While jail hurts it actually solved my problem. And since the “stuck in combat” was hilarious at the beginning since a dude started to attack me for apparently no reason I started to hit him back. This was over at the Church building site. After a short time we were around 10 guys fighting this one “immortal” attacker. I accidently hit one of the guards since they were all over the place. I had to leave and went on horse to another city but i was still stuck in the fight. So I wanted to try jail time and it worked.

Anyway got out of it with 3 perks and many more level ups :wink: It was a gangbang fist fight for sure.


#19

Same thing happened to me.
I solved it.
Ride back to any town. Talmberg is closest. punch a guard until it forces the cutscene. handle the business, pay the fine, or talk your way out. when the cutscene ends try to wait and if it lets you you’re out of combat.


#20

This is still an issue. Scouted the camp, but can’t get out of combat at all. Can’t save, can’t fast forward time. Stuck in the middle of the night with everyone asleep. Guess I can go slap a guard :stuck_out_tongue: