Waldensian Quest Bug & Ladder Climbing Bug introduced with 1.6

Hey guys,

still like the game but some bugs are getting beyond frustrating and game breaking.
I cannot finish the Waldensian quest because the cutscene in the loft in the “Bauers” house is not triggered (I went up there way before 21:00).
I cannot wait using “E” button like prompted, I have to do it manually and still sthe cutscene isn’t triggered. It doesn’t matter how long I manually wait, still the cutscene is never triggered.
I tried to load a save from before accepting the quest - still no change, same bug.
I am really getting tired of this. Luckily I have a save from before accepting the quest which doesn’t cost me much playtime, still it is very frustrating.
In my opinion the game isn’t playable without the mod which allows you to save whenever you want. I had so many bugs or crashes since I started playing the game again with version 1.5 - hoped for better, still mostly disapointed about the overall quality of the game.
Is there a workaround for my problem or even a fix?

Also there is a new bug introduced with version 1.6 of the game where when you climb up a ladder where it spins your character around when you reach the top and then lets you fall back down. I found a workaround with not pressing any buttons when I reach the top. You still spin but not fall back down. You have to be a bit careful though.


1 Like

Try to deinstall the mod and play the quest again.

In Version 1.5 the quest worked. The problem is caused by mods…
Don’t now if there is a “new” bug in 1.6…
If yes send a bug report to

Just dropping a note here for posterity: I also encountered the problem where clicking on the “Wait” button does nothing in the Waldensians mission.

Solution: uninstall the “Perkaholic” mod.

I have some 40 mods installed, and went through them one by one to find the mod actually responsible for causing the problem. It’s not the “Save Anytime” mod – I have that installed, and was able to successfully trigger the cutscene at the farm but only after disabling “Perkaholic.” (In my case, Perkaholic v1.7. A later version of this mod may solve the problem; I haven’t tested any other versions.)