Weapons not arming after ruby battle

After baptism of fire is complete and I am in Rattay. On ps4 …my left and right d pad to arm weapons does not work at all.
Up and down work but can not arm weapons with left and right d pad respectfully
I have unequiped and saved it did not fix
I have traveled to another city and unequiped
and saved …still does not work
I have unequipped all armor and weapons and re equipped all … does not fix

Also is there prerequisites to do before the battle
Like talk to or do certain quests

Any help would be appreciated because the game is unplayable right now since I can not fight

Can you punch? Ive had similar stuff happen but i could unequipt weapons and punch a bit then it started working again also sleeping 24 hours worked another time or killing yourself and reloading…random stuff fixes it i think. Ive not had a permanent glitch though

1 Like

Also, welcome to the forum. KCD is a great game with an equally impressive community.

1 Like

Yes tried punching and taking everything off and sleeping
PS4 the torch short cut with hold left d pad does not work either
If I manually put equip torch in menu it comes up but d pad will not work left or right
Did sleep saves and snapped saves still
Can not a weapons with d pad or any other action
Please devs game is unplayable
Also can not bed sleep at any bed

Have been stuck at this point for months tried over and over from Rattay and always does this after the battle with runt

Can not fight or finish game grrrrr

1 Like