Bird in Hand quest still bugged?

I never had a problem with this quest in normal mode, and thus wasn’t aware of the bugs associated with this quest for others.

But now I’ve started a hardcore playthrough, doing this quest, and one of the traps has set itself (it has a map marker) inside the huntsman’s building in Rattay, but it’s simply not there. I suspect it’s on the roof or perhaps in the ground? Is this a known bug?

It appears to have teleported from the pine forest where I set it, to the huntsman’s house/area.

Any suggestions as to how to fix this? I assumed this quest had been fixed given all the troubles from before, but it seems not.

1 Like

XBox One: Patch 1.5
Can’t help you with the fix, but I’ll confirm that is exactly the state of my “Bird in the Hand” quest.
Even though I had set the traps initially in the prescribed area, 2 of them now appear in the Quest Givers house, but can’t be found.

You need to be patient and take your time. If you do not follow the events of placing the traps in sequence, like fight the bandit camp, you will have a frustrating ime completing the quest. Avoid the bandits and concentrate on the bird traps and you will be fine and complete the quest with minimal frustration.

like @glansky said.
fight the bandits but don’t start the quest until you clear the area… Or do the quest but stay clear of the bandits, finish and do them after. Also drop one trap at a time and , then collect one at a time . Don’t drop more than one.
1.6 patch fixed and sped up the trap time for the catch so go off and pick some belladonna while you wait.

XBox One Patch 1.5

I had set the traps prior to realizing the bandit camp was there.
Have since cleared the camp several times since.
Only one trap remains in place.
Someone took two of the others back to the quest giver.
Is there a poltergeist NPC in the game?

Sounds like a save go back is needed to fix. I have done this 2x in the past when the quest was really buggie

1 Like

Redoing the quest would require me to load a save that no longer exists.
I’ve probably played 60 hours since the initial quest and was waiting for a patch to fix it, which I thought was mentioned in one of the patch notes.
But because of problems posted with the later patches, I haven’t loaded the one that was suppose to fix the bug.

2 choices then , neither good ones. abandon or massive go back. IMHO you are S.O.L. and screwed on this. My condolences.

1 Like

I’m wondering if these games won’t bring out full blown OCD for those who are borderline?
So many people seem to be hung up on such small quests.
For me, no big deal.
I already moved on, but it would have been nice for WHS to have fixed this by now, especially for future gamers, or those starting over with a 2nd play through.

1 Like

1.6 fixed the quest. When you get around to it is at your end and remember to save before doing it.
I was doing it in 1.5 successfully. just had to do a save before doing the traps one at a time and no messing with bandits.

Some quest do require doing it in a certain order and/or time frame.

1 Like

Thank you all for your input and findings.
Fortunately I had a relatively recent save I could revert to. Despite a bandit interruption (and their subsequent demise), all three birds could be returned and mission complete. I’ll be sure to check through all the other extant bugs so that hardcore mode isn’t made even more hard by broken missions!

1 Like

Yep exactly what happened to me.Searched everywhere. Tried various suggested fixes (loading nexus mod and putting bird traps in inventory, putting empty cages in inventory etc) Nothing worked!! The marker was p***ing me off so I murdered the Huntsman. Quest failed, marker gone RESULT :slight_smile:

I have been able to accomplish the quest, even before the patch. It is a bummer, but restart the quest. If you place all of the cages all at once instead one at a time you will lose a cage or two. Be patient place on cage, wait one hour and collect the bird in the cage, repeat the procedure each time. It is time consuming but that is how I was able to complete the quest.

I’m that borderline OCD MF you’re talking about. ALL 3 cages went AWOL, bugging the crap outa me leaving that quest. HC mode only 1.9.1 :face_with_raised_eyebrow: