Bug Miller Pickpocketing


#1

So I have this very shitty situation where I was to stupid to get pickpocketing. I tried with the Miller like 15 times. Then I watched a video and realised what I was doing wrong. As I tried to get to the miller again he tells me to get is dagger but then minds his own business and i am not allowed to pickpocket him. To me this seems like a bug and hinders me on doing anything else with him but having this “get my dagger” conversation. PS4 Pro Updated all on newest version (CH)


#2

I dont think its a bug
the pickpocket quest was just over and now its not available anymore and he wants you to do something else
you can try to pickpocket other people or reload a savegame before you started this quest.


#3

No when I talk to him now he says “try to steal my dagger I will stand here etc etc” so like the quest conversation but he is walking around his mill and i didn’t succeed in stealing his dagger also the quest is still active but like this I can’t complete it


#4

ok I see
have you tried to load an old savegame?


#5

well that was hours ago. I failed the quest then I did other stuff and now I came back and tried to shortly complete it and realised I’ve broken it… I’m not really willing to give up on all the stuff I stole/got and achieved. Also I tried restarting the game, loading the most recent save file and sleeping. Nothing worked


#6

I have the same issue. Failed pickpocketing miserably and walked away. Picked up the skill somehow but now any dialogue with Miller is only about attempting to pickpocket him again (exact lines from initial attempt). The only problem is that he doesn’t move from his position or walk to the back of the stable as he did before.

Unable to reload as I am hours past that quest.


#7

well I stick to woyzeck for selling stolen stuff now. I got myself a horse for around 140 bucks so its ok now as you can fast travel to a near village. But I guess fixing this would be possible by update… somehow changing the way the game checks for the quest and then directing actions/possiblity to steal from him or so.


#8

Same problem here (PS4), but i managed to get the pickpocketing skill. I hope the Miller wont play a big part in the game anymore, or that its going to be fixed.


#9

I ran into the same bug myself. After I was able to get the dagger the quest didn’t complete and it wasn’t in my inventory. The miller was still stuck on wanting me to try to pickpocket him but I didn’t get the option anymore.

I found a way to try again. I waited around until the next day(since it was night at that point). The miller had walked back to the main area. I spoke to him and asked to try pick pocketing again so he walked back behind the mill and I got the option to try again. I am not sure if this will work before the recent update since I already had updated the game. I hope this will help as a work around for anyone who gets this bug.


#10

What time of the day did you do this at? Gonna see if I can do what you pulled off. @chaos1979


#11

Yep same problem (pc)


#12

Still stuck on this. What a drag. I have finished another quest he sent me on but I can’t get him to talk about it. He’s obsessed with me trying to pickpocket him.


#13

There’s also a bug with his locked chest. It doesn’t lock anymore. It’s a shame he is the best person to go to for free skill boost. Now both his pickpocketing and lockpick training is bugged. I hope WH fix this.


#14

Great. I didn’t know about that one.


#15

If they just put in a way to delete a quest, you know?


#16

It’s a bug, you can’t do anything about it, if you leave the quest fails and he acts normal again. However you aren’t missing out on anything since you could just replay that quest as many times as you like but you got no reward.


#17

I am missing out, though. I can’t finish ANOTHER quest that he gave me. It’s all done but can’t finish it because he is stuck on the pickpocket quest.


#18

The quest should have failed once you leave and fast travel away, if it doesn’t then you’re probably screwed like almost everybody else who has tried to play this game because there are literally hundreds of bugs in almost every aspect of the game.


#19

LOL yeah you are right. I’ve fast traveled away, fast traveled back, done somersaults and sung Dixie backwards.


#20

I’ve come to the revelation that I should stop playing this game.