Crashes after 10 mintues of gameplay on 1.8.1 (PC)|Being investigated by WH, please scroll to the bottom of the thread


#21

EDIT: As I just contacted warhorse, here’s a more detailed describtion

I really enjoy KCD as the great game that it is, but unluckily I have experienced heavy crash issues since 9th of February this year. After about 30 hours (33 days ingame time) of gameplay without major bugs nor a single crash, the game became mostly unplayable for now. It all started with a sudden crash to desktop without any type of error message. I restarted the game and jumped into the same savegame again which led to crash the game again after about 10-15 minutes. This pattern repeated over multiple tries, but I noticed when loading older savegames it took longer for the game to crash. This leads me to the conclusion that the crashes are maybe connected to a certain ingame time or a mission that causes the crash. Those crashes are repeatable and occur every time. I went through all common sense troubleshooting steps without any result as described in detail below.


Detailed description of the Crash

-Game ran fine on high settings (even on long sessions) for about 30 hours without any crashes or major lags
-A sudden freeze for about 2 seconds occurs followed by the game crashing to desktop
-First encountered while hunting for one of the Beggars‘ Feast missions
-Seems to affect every savegame at roughly the same ingame time (and maybe ingame date) as older saves use to run longer (>1 hour) than newer ones (about 10-15min)
-I haven’t changed anything in between. Neither in the system nor in the game settings
-No error message from windows, just a clean crash to desktop
-No report in Kingdom Come’s log data
-No increased CPU or GPU usage before the crash (about 17% average CPU usage and 55-65% GPU usage with 7-8 Gb of RAM used)

Troubleshooting steps I have tried:

-Trying other savegames: No fix
-Did a backup on the savegames then deleted the original folder and swapped them back in: No fix
-Disabling steams cloud service as it may contains a corrupt savegame: No fix
-Uninstall the game, delete every folder connected to KCD on the whole system, reinstall and swap savegames back in: No fix
-Updated and checked all drivers to exclude any kind of sudden driver issues: No fix
-Running as administrator and in compatibility mode for Windows 7
-Cleaned the registry just to make sure: No fix

Windows' maintenance report: (sorry for it being in german)

Problemereignisame: APPCRASH
Anwendungsname: KingdomCome.exe
Anwendungsversion: 1.8.0.0
Anwendungszeitstempel :5c5061df
Fehlermodulname: WHGame.DLL
Fehlermodulversion: 0.0.0.0
Fehlermodulzeitstempel: 5c506df6
Ausnahmecode: c0000005
Ausnahmeoffset: 00000000007a8f9e

Active Missions (maybe that helps locating the problem)

-On the scent
-Vengeance
-Beggars’ Feast
-Raiders
-Thick as Thieves - Woyzeck
-Thick as Thieves - Peshek
-Do Me a Favour - Punch Me!
-Rob the Rich, Give to the Poor


#22

Yup, looks eerily similar to what I’m experiencing.
I’ve sent a bug report with corrupted savefile to support@kingdomcomerpg.com, but I highly doubt that I will get any response soon, at least not before workweek starts


#23

This is the exact same problem as me! :frowning:


#24

@Light_Bringer_17: I have about 60 hours on my saves, I havent progressed very far in the main story, been avoiding doing so because I like doing my own thing. I do also use Ultimate Saving mod, I like being able to save where I want, without having to use some stupid Saviour Schnapps item. I dont even drink IRL, so the idea of having to get drunk to save annoys me.


#25

I don’t kill IRL, so the idea having to kill annoys me too


#26

After the third mission of the band of bastards the game crashes everytime I want to open a map or inventory…


#27

make sure to send this to their support team via email, so they make this a priority.


#28

@ShadowFox: Was that meant to be sarcastic? I know that some people try to play KCD without killing, but realistically, it’s hard to play the game without doing so.

I dont use drugs or alcohol IRL, to me it’s a matter of keeping myself free of mind-altering substances. Both for medical reasons as well as my spiritual practices (a mix of meditation, yoga, and varying Buddhist practices, although I’m not Buddhist or any other religion). The few times I have drank beer, liquor, wine, etc, I didnt like the taste at all. My Henry shouldn’t have to get drunk to save.


#29

you’re not Henry. You’re roleplaying as Henry. There’s a difference.


#30

@cnotnkay: Yes, I understand your point. It’s made clear in the beginning of the game that Henry does drink. But to a degree I subject him to my personal beliefs. In the game I am a murdering, thieving bastard, although I obviously dont do those things for real. It’s a game, so why not have fun doing things that would get me in trouble IRL.


#31

Stop derailing the thread guys.

I have the same issue on PC. Started happening after playing for about 25-30 hours on my save, after the Runt fight.

If I reload an earlier save I can play for a bit before it starts happening again. The older the save file the longer I can play before it starts to happen, so maybe it’s tied to how long you’ve played.

Tried going back patches, repairing/verifying files, reinstalling, changing graphic settings, clearing save folder etc. but nothing works. Crash to desktop after 1-10 minutes of playing every time.


#32

Yep, same problem for me. Almost 300hours in-game with not one single crash, then had 4 just this evening

KCD Build(0) 10 Feb 19 (22 19 36).log (14.3 KB)


#33

Yah, I did. Sent an email on Fri evening. Don’t expect any response before workweek starts though


#34

fwiw, played 1.8.1 on vanilla PS4 to see extent of problem (cross-platform?).
Didn’t have any problems unique to 1.8.1 vs 1.8.0


#35

Having the exact same issue. My save is about 24 hours in and the game crashes constantly about 5-10 minutes after loading. I’m pretty sure this is quest-related because my hardware can support the specs and the graphics are optimized. I’ve been playing version 1.8.1 the entire time. This issue just started happening and it’s very frustrating because the game is unplayable now! :frowning:


#36

it’s not quest related. go back an hour and do a different quests or speed through them. it’ll still crash around the same “hour”. i’ve tested this myself. loaded a save an hour before crashes started, skipped dialog and cutscenes and completed the two quests just fine with out crashing once. but once “that hour” came, the crashes resumed.

my save hour is 20.9. i kept crashing when trying to start “The king’s silver” or finish up “Questions and Answers” to start “All that glisters”. so i loaded a previous save at 19.1 hours and sped through questions and answer, pestilence, the king’s silver & all that glisters with out a single issue with in 45 minutes. then idled about till my save time reached 20.9, then the crashes started again standing in the middle of no where. so i loaded it up again and instead of doing nothing, i went ahead and started walderasians quest and it would crash when i get near rattay because it reached “20.9” hour.


#37

From reading and searching about this all over (Here, Reddit, GOG forums etc.) It seems to me after playing a certain amount of time on any save file on this newest patch you will start crashing.

From what i can tell:

  • It crashes after a specific time of playing
  • What quest your’e on doesn’t matter, I’ve seen people on multiple different quests with the issue
  • Total playtime doesn’t seem to matter, I’ve seen people with 5 hours up to even 300+ hours having this issue.
  • It’s reported on all platforms.

So the bug is that after playing some time on the newest patch something gets fucky with the save file making it crash.

Does this match your guys experiences?


#38

My experience definitely fits to what you described above. I play the game on PS4 platform and I experienced the game without any problem for 30 hours until friday night, when the game was updated. For me, it is obvious that after a certain time you face with a crash problem, no matter what you do. I tried to load very very early save games and althought it let me play a few more hours, eventually it crashed.

I hope developers are aware of this problem and an urgent fix already on the way.


#39

Matches almost exactly. Except - If I start completely new clean save on this patch - the problem doesn’t appear. Not sure if I’m too early yet, but I’m about 16 hours in from weekend session and so far it looks good. The biggest pain is that it’s happening after you’ve invested so much time into a save. It’s not like this game is painless to restart


#40

And i hope the guys who screams for a second game should now be damned with her game! XD It does not even make sense to archive the updates. So WH will not got its own hard disk like Half-Life by me. 680