Failed to load WHGAME.dll Possible fix (worked for me)


#1

I’ve seen quite a few topics about this and none of the solutions works for me, tried checking file integrity; didn’t work, tried deleting the WHGAME.dll and verifiying and didn’t work neither. What’s wrong exactly ? What causes this error?


#2

try to go to properties,local files then confirm are all the files here (sorry for my BAD english)


FAILED TO LOAD THE GAME DLL ! Please help!
#3

Tried already, deleting the dll and verifiying the files doesn’t solve the problem neither


#4

sorry to hear that, look for the dll on internet


#5

I’m not sure searching for this specific game dll in internet will work, it’s a new release, wouldn’t find any.


#6

Yeah same problem. Deleted whole bin folder and repaired, but still same. If I try run it as administrator from folder I got little different error which after confirming leads to same arror like from steam. Faile load WHGame.dd


#7

Yeah, i’ve tried everything, reinstalling graphic card drivers, reinstalling directX, none of them worked, seems like the installer is corrupt or something.


#8

You are not the only one who has not found a solution to such a mistake …


#9

If you find out solutions write here


#10

Sure, i’ve personally contacted warhorse studio via E-mail to get some responses to these problem, or at least to know if the’re aware of it and itend to fix it.


#11

We wait…


#12

I just wait until tomorrow and hope they gonna fix it. :slight_smile: Or maybe just try download it from torrent during night, its a shame but usually pirated versions work better than original. :frowning: I dont have ultra speed connection to try install and uninstall few times or spent whole day to try to solve it. Backed this game 4 years ago with my money, so its not up to me try to find solution, I am a customer here, so waitincg for patch this. :wink:


#13

Снимок Such an error?


#14

Ineed, i’m also downloading a torrent version and will try to swap the problematic dll with the torrent one, shamefull but sometimes happens, hope we get a response soon.


#15

UPDATE: Got a response from warhorse studio support ;

Hello,
try downloading newest VC redist from official Microsoft page: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads

QA Team
Warhorse studios s.r.o.

This didn’t fix the problem for me, you may wanna give it a try tho.


#16

No I did it all before. Drivers, DirectX, C++, antiviruses etc was waiting for game like 4 years wont kill me to wait another few days :D…anyway didnt finish assassins creed yet so until than i am good :smiley:


#17

Yeah, i have not problem waiting for a few days to get patched and hopefully fixed, but what if is a problem with our PC and not the game? Who know’s nevertheless some people would like to fix it the sooner the better.


#18

IMPORTANT UPDATE! Try copying Win64Shared files to win64, this worked for me and the game now launches correcly!


#19

Works for me…Great…Time to play :slight_smile:


#20

Sadly all of this didnt work for me… any suggestions?