I want to finish the game, but I don't understand it


#1

I have made it to the quest where I have to interrogate a captive in a village where Melichar resides. Thus far I have become extremely annoyed on several occasions because there’s always something blocking me from finishing a quest. I always need some random item without warning, and have to back track and waste 20 minutes of my life , or the game is prompting me to complete a quest, and the game refuses to let me do what the game is asking me to do. Right now I can’t talk to the captive because the guard wants me to talk to melichar, but melichar will not speak with me. In situations like this, i literally have no other options. I run around the entire town trying to talk to anybody, and it doesn’t help. I try sleeping, cleaning myself, changing clothes, closing the game and re-launching, and nothing works. This is why i don’t play KCD. I want to play this game very bad, but I don’t know what to do. So this post isn’t so much about this specific quest as it is the game in general. What are some tips i can use to finish this game without running into this problem every other quest? I pay attention to the dialogue, so it’s not that. It’s like i’m missing something and i don’t know what it is.

I am completing the game through the main story line. I am following directions as they are written. Yet, there’s always some random amount of improvising required that isn’t mentioned in the quest instructions. This is what I have a problem with. It’s always random and off the wall, and there’s no way I could have known. I always have to log in to these forums and ask people, and wait 20 minutes for a response on the forum, so i can then go back into the game and finish the quest. I hate this so much. It’s always something like “oh well, in this quest you have to go to some random location and learn some skill, and then return” and i’m like ??? where was that written???


#2

Maybe try a guide instead of this forums.


#3

You can take a look here for example:


#4

Yes, I have done that already. But it’s ruining the game for me. When I play the game through the main quest, the game doesn’t provide me with the information I need to finish the quest. Having to search the forums for random information is ruining the game for me. I don’t want to have to watch videos and ask other people. I want to know how to extract the data from the game so I can play it myself. I’ll record a video and show the forum the issue I’m running into often, so that it’s easier for somebody to help.


#5

This game does not hold your hand at all, so you will be hard pressed to find a marker as to what is your next task is. I agree that it is sometimes a hindrance, but most of the time it encourages exploration and random encounters. if you really get stuck just use Google lol.


#6

Yes, that’s exactly it. I don’t have 4 hours to ride around on the back of the horse in the game to find some random bit of data. I have no idea who has the time to do stuff like that. I’ve got a pretty busy life outside of this game, so when I’ve got a spare hour or two to play the game, this is the sort of stuff I run into. I don’t want to spend an hour trying to figure out what to do next when I’ve only got an hour and a half to play. And then when I do eventually figure it out, I’ll have to save the game and come back a few days later, stuck in the same situation where I’ve got an hour or two to play, and I’m back in another quest that isn’t helping me , or providing enough data. At this rate it would take me a couple of years to finish the main story. Also the game itself is very inconsistent. One minute it’s showing me where to go, and how to complete the quests on the map, the next minute the game expects me to be a mind reader. That’s most of the problem. It’s that the game randomly decides when it’s going to give me the data I need. If it never gave me the data and required me to explore, I would know to go explore. However, half of the time the game doesn’t require me to explore, so i never know if I’m missing data, or if i should go explore something.


#7

I got stuck I think only twice through my play through, but never for 4 hours lol, but admittedly it was in the early days and the game was glitched so a NPC was not showing up, but it been patched since then


#8

So help me please. If you were able to complete quests in the game, in scenarios where the game isn’t providing you with information. What did you do? Surely you didn’t just start traveling around random towns interacting with strangers? Right now I’m in a situation on the main quest where I talked to a captive in the quest “pestilence”, and the game wants me to help the captive before i can talk to melichar. I have no idea where to go to help the captive, and it’s not showing up on the map. Half of the map is covered in clouds, so I wouldn’t begin to know where to go. If i go to the quest log, there 0 data in the main story that guides me to a location. If i go to the side quests it tells me to go talk to johanka, but again, I’m not trying to play side quests. I’m trying to do the main story and complete the game, as it’s already taking long enough as it is. What would you do in this scenario? I dont want to do side quests, and I don’t know how to help the captive. And even if you tell me how to help the captive, i still don’t know how people are extracting the data from the game without several hours of spitballing.


#9

This is why it’s so hard for me to get help with this game. It’s not the specific quest itself that I’m having a problem with. It’s that I don’t understand how people are able to discover the missing data without 4 hours of random roaming around , or forums, guides or videos. All of that stuff is inappropriate in my opinion. I didn’t spend 60 dollars on a game so I can play it with data outside of the game. If there’s a guide required to play the game, that should be included in the cost of admission. what if i didn’t have internet access to look up a guide? why would i want to do that?


#10

You have to heal the town first


#11

Yeah, and i have no idea how to heal the town? I don’t want you to tell me how to do it, i want to know how you knew where to go to heal these people. How do i know where to go? to be specific, i don’t want you to tell me how to complete the quest. I want you to tell me how you were able to figure out where to go to complete the quests.


#12

You have to go to Johanna. Once you help her you will have an option to help one of the monks that will teach you the recipe for the cure. Once you have the cure you go back to the village and heal its sick members including the guy you need to extract the information from


#13

Even your mention about healing the town isn’t actually mentioned in the main quest anywhere. It tells me to do the following. A - Interrogate the captive. B - Help the captive. That’s it. It doesn’t mention healing the people in the town, or talking to johanka on the main quest. That’s all side quest stuff.


#14

Are the side quests mandatory to finish the game?


#15

Not really all but I think this one is tied to the main quest cause its part of gathering the info for radzig, so I think you have to do the side quests


#16

This is the 77th quest in the game, and it’s just now randomly expecting me to start completing side quests. Is the game going to continue doing this? This is very upsetting. This game is not put together professionally if what you’re telling me is true.


#17

lol like I said, the game does not hold your hand, and that this game is also wh studios first game, so year it has some issues and is not perfect, but give it a chance and try finish it, it really is a good story


#18

This isn’t about holding hands. It’s about the game being extraordinarily inconsistent. I don’t have a problem with exploration. I have a problem with the game’s consistency then. I haven’t done a single side quest since I installed the game. How in gods name would I know to start doing side quests to complete the main story? Apparently by coming to the forums and asking people, but why? that’s so lame.


#19

Lol I duo then. I did not find it that hard really, but I cant speak for others. My biggest problem was I play it on a Ps4 pro, and it had crappy graphics/lag/horrible popins most of the time.


#20

I would argue, the game holding my hand is the entire problem, not the other way around. I can provide you with dozens of instances where the game holds my hand by telling me where to go, who to talk do, and what to accomplish. It’s that all of the sudden randomly in a quest, the game just stops giving me information. If the game would have never held my hand in the first place, i would have developed a formula or system for figuring things out. Meh. Unfortunate. I’m glad i came here for help, because I think i’ve finally figured out what’s going on. For a while I thought I didn’t understand the game. Now I’m starting to realize, it’s just inconsistency, and unprofessional game design.