Nest of Vipers / Sabotage help?


#1

I’ve tried this mission about 27 times already, and every time I fail.

I have tried to go at night, and during the day.
I have tried poisoning the entire CUMAN side 2 pots, and destroying 2 arrow’s
I have tried to equip the cuman outfit in the chest , but I always get spotted and taken to morecock.
If I try to poison all the pots on the cuman and bandit side, and light all 8 arrow chests, I die. There are no examples of anybody actually completing the sabotage online or anywhere for that matter. They’re all getting the same “completed” indication while they’re in the camp, and then they run away. I get this as well, but as soon as I tell radzig, the mission claims I failed it.

There are a dozen videos of people doing this mission, and they all fail. The reason is because the game actually tells you that you’ve completed the sabotage while you’re in the camp, and tells you to run away. When you report to Radzig and tell him that you’ve sabotaged the camp, it says failed. Everybody keeps telling me I don’t have to worry about doing the bandit side, and to only do the 2 pots and 2 arrow chests on the CUMAN side. This doesn’t work.

The reason this is confusing me is because the game is telling me that I’ve completed the sabotage, and then after I tell Radzig, it says I failed. So I really don’t know what the game wants from me?? Why is the game giving me a green checkmark after I poison the 2 pots and light the 2 arrow’s on the cuman side, and then prompts me to run away if this is still a failed mission?? I don’t get it.

If I poison 2 pots and destroy 2 arrow’s on the cumans side, does this even impact them before the battle if it says I failed? <~ this i really want to know.


#2

Haven’t done this mission on 1.8 yet but on older versions it was going smooth and nice if the stealth is high enough. Don’t remember failing it after I leave the camp. Usualy I poison all the pots (mission says 3 is enough as i remember) and burn all the arrow barrels (2 is enough) and stealthkill a bunch of cumans and bandits on the way - not realy necessary, but helps to sneak trhough the camp and to scout the attack routs. And cuman outfit stuff never worked for me sadly.


#3

So it’s 3 pots, and 2 arrows?


#4

Not sure, far from it on current playthrough. Anyway don’t forget to scout all 3 attack routs.


#5

Yeah, I do an entire lap around it and scout all of the routes first. I’m only failing the sabotage part. But I’m only doing the CUMAN side. Everybody keeps telling me to avoid the bandit side. I’ll try 3 pots and 2 arrows. If that doesn’t work Idk what to do. It’s crazy that there’s 0 examples of anybody successfully completing this online.


#6

To sneak into bandit’s camp you have to kill at least 2 of them usually - they’re always guarding the only entrance. And that’s tricky.


#7

False, they don’t guard the entrance that has the crate you lockpick that has the cuman uniform. That’s where I usually go in.


#8

There are 4 pots and 4 arrows, 2 in each camp. You need to do all of them to properly complete it. For me it only completed that optional part once I had done them all.


#9

Nope, I mean the bandit side, not the cumans.


#10

The message of completion indeed pops up when last pot is yet unpoisoned.


#11

The message pops up and tells me I completed after I do 2 pots and 2 arrows, and the game tells me to run away or return to morecock. I have it recorded. I can post a screen if you want to see it. You’re not being very specific, and I have no idea what you’re even referring to , so this is getting confusing.


#12

You see what I mean??? Everybody tells me something different. WHYYYYYYYYY


#13

The bandit side is near the church and has but one entrance - it’s allways gurded by two bandits.


#14

But listen… You say 3 pots, and 2 arrows. The other guy says 4 pots and 4 arrows. The game told me 2 pots and 2 arrows. One guy told me to ignore the bandit side and only do the cuman side. You’re telling me to go in the bandit side?? Everybody says something different. It’s because nobody actually knows. I don’t know why people do this. Should I start a poll and poll the audience?


#15

There are 4/4 usable stuff in whole camp. Sidequest marks as completed by 3/2 (maybe at 2/2 as you’re saying).


#16

When I poison 2 pots and burn 2 arrows down on the lower side (I believe cuman), the game tells me I completed the sabotage. But it’s lying to me.


#17

Yep, you have to go on bandits side aswell.


#18

Well, I guess I can add that to the list of broken game functions.


#19

Weather you poison all of them or 2 of them, the end result is the same. Tell Radzig you did some sabotage and move on. Some quests can be failed, it happens, deal with it.
Try and sabotage all of them and if it still fails you then it is a bug.


#20

But I don’t know if it’s going to help me if it says failed. The next mission we go there and fight them. If I don’t complete the sabotage correctly, the fight is going to be more difficult. It matters. That’s why I’m asking. I want to know how to do this properly because the game is broken.