Nexus Mods Wont Work

I tried to install 4 mods, and I am sure I did it correctly. The 4 Mods Were, Perkaholic, Roads_Are_Dangerous_Nazivu, Instant Herb picking and Stay clean longer, get dirty gradually. None of them were working and I am sure I did it right, can someone help me out?

So what exactly did you do to install them, first of all?

@Loco_coco , have you read the latest from Christian?

haven’t tried… does Vortex play nice with KCD mods?

the wiki doesn’t say one way or other but i’m skeptical

I had troubles getting my one mod (unlimited saves) to work as well. I reinstalled the game, launched the game and… nothing. Didn’t work.
After that, I checked the ‘mods’ folder, it had been renamed ‘old mods’ (yes even the one I just made myself). What I suggest you do is make sure everything is in order, launch the game, alt-tab and check the KCD folder (computer/c/programs/steam/steamapps/common/kingdomcomedeliverance and make sure the mod folder is named ‘Mods’.
I hope this helps.

There will be proper mod support later, right now mods are still very risky as we are still updating the game via patches, which is causing problems in the combination with mods, especially if you use savegames from various game versions.

Ensure that your mods have been updated for the game version 1.9. Otherwise they will not work and can ruin your game. The “Roads are dangerous” has never been updated, so it’s definitely incompatible. Others may be, too.

1 Like

The problem is, that once corrupted savegames will probably not fix themselfes anymore, even after updating the mods.

1 Like

I can approve this. I once had broken one sidequest since like 1.43, then updated 1.5 and it was still broken untill latest updates because NPC was previously telepored elsewhere and meanwhile it got cancelled after entering Vranik. I kept playing the same playline. I didn’t get there yet in new walkthrough. And never got any mods installed it was just a bug that got fixed later.

Sorry for taking so long to respond, the reason they wouldn’t work is that I am a dumb ass, more specifically is that they simply don’t work in the latest versions. Sorry for wasting your time.

1 Like

No worries mate, it happens to the best of us