Okay FPS but constant freezes

I’ve played approx. 6 hours yesterday and only ran into 2 of the freezes, both lasting about 2 seconds. I was getting these same freezes every few minutes before. My overall fps is higher as well but not by much.

Windows 10 is kind of weird. I noticed that if you turn off Windows Defender’s realtime protection and it’s firewall portion that it actually increases the CPU usage of Windows services (svchost, etc.). Seems counterintuitive but I’d leave those running for the best performance.

Same here, still some rare but very short freezes. Nothing in comparison to the previous ones though. Really happy about your tip.

Thank you, tinklepee for a more radical solution. Seems to be working, so far. Would have waited days, maybe weeks for a patch to fix this. Going to delete all saves to this point and start again. Thanks VERY much.

1 Like

Any solution for those who stuck with win 8 ? =((

Same problem here.
The game runs smoothly for 3-4 minutes after boot and begins to lock up and freeze suddenly for anywhere between 30 seconds and 5 minutes. Then it will run smoothly for 5-60 seconds and do it again, indefinitely. Settings and current in-game situation have no effect. My video card HUD clocks me using only 50-70% of the GPU, using only 1.3 Gb of 2.0Gb of VRAM with an average of 60fps. I’m also getting the CPU spike during the freezes. I also never go over 8Gb of regular RAM usage.

I also noticed that “Fullscreen” makes it very noticeably worse than “Borderless” does.

Unfortunately I’m not willing to “upgrade” to Win 10, so that’s not a solution.

i5 4570 3.2 Ghz X4
GTX 770 2Gb GDDR5
Win 7
All drivers are updated

It’s a great game otherwise! Good job Warhorse!

I might have found a solution for those of you using an Nvidia GPU!

  1. Go to the Nvidia control panel
  2. Select “SLI and PhysX Configurations” (may just say PhysX for some of you)
  3. Select your GPU under the “PhysX Settings”

This worked 9/10 for me. I still have little baby freezes that feel more like momentary glitches, and they happen so far apart I forget it’s a problem sometimes.

Also running in “Borderless” as opposed to “Fullscreen” helped a bunch.

Hope that helps some people!


Sadly, I already tried that, didn’t help.

Also, the freezes happen just as often when playing in Windowed mode, will try Borderless now nevertheless. Doubt that alone will help, though…

Thx for that hint. It kinda helped me, allthough I still get freezes from time to time.

Tried to upgrade to Windows 10 but that`s another story :stuck_out_tongue:

Borderless is bad for framerate though, I was getting 20-40 in borderless and I’m now at 30-50 in Windowed mode.

I have the same Problem.
I5, 16 GB Ram, GTX 1080, Win7. No matters if i play with super high or medium graphic settings. Game will freeze every 5 Minutes. Before tamberg it was better.
I have sometimes 120 fps, but the game freezes anyway.
But i can’t/won’t update to win10. I have some software installed who needs win7.

i will try the windowed mode, an the physx settings this evening.

I got:
RX 580

I tried everything. EVERYTHING. I didn’t try only win 10. Any other suggestions how to fix on AMD videocards?

Also had continuous stuttering (5 second freezes) in town on a 3570k @ 4.3ghz. Upgraded from Win7 to Win10 and practically all of it is gone, there are very rare 1 second stutters related to my weak CPU but that’s all. Unfortunately this game still seems to be very heavy on CPU usage in general, and when I’m walking around in Rattay for example I can expect 100% cpu usage all the time. No idea what can be done to reduce this somehow…

changed the window settings to borderless(? not shure, how its named in englsih). now it works fine with win7.
Just played 3 hours with graphic settings on high, and had just 4-5 minor freezes.

The game is full of areas where brief microstutters happen. The fps jumps up and down. This is enough to disrupt the whole experience for someone like me who is used to butter smooth stutterfree gameplay on every single game out there at max settings.

A perfect example is in Rattay when you sprint from the bathhouse towards the stream of water. I am able to produce a microstutter there every single time. A lot of people here ignore these microstutters and claim 60fps+ solid. That is NOT 60+fps solid.

PCGamer and JokerProductions have all pointed out those sudden drops regardless of setting.

Gtx 1080 Ti (390.77 WHQL driver)
i7 7700k @ 4.6Ghz
16GB DDR4 RAM 3200Mhz
Samsung 850 Evo SSD
Win 10 Pro 64

Also CPU Core 2 is always at 100% or near 100% usage regardless of location. here is an example:

I found a solution how to get rid off freezes. You need to download “Battle Encoder Shirase” and target the process “Kingdom come” after launching the game and set CPU - 1%. Be Happy

It works! Thanks!
Also the loadings are moooore faster.
Now i’m stable on 35FPS With a GTX950M i74720HQ 8GB RAM
All at minimum.

EDIT: After the first “Chapter” the issues comes back

I tried this and sadly that changes nothing for me… :confused:

I sincerely hope the devs are reading this topic. This is a big issue that needs addressing. I seriously don’t wanna upgrade to Windows 10 (I also have programs that only work on Windows 7). I also don’t believe it’s a GPU related issue, since lots of users up here are reporting the issue, even with high end GPU cards. I hope this gets fixed in a patch in a near future. It’s REALLY annoying!

Here is what you need to try. After launching the game you should go to Windows Process Manager, click on Kingdom Come process and localize the core that is 100% or almost 100% utilized. Then right click on the mentioned process and select: Set affinity. Deactivate the core that is ~100% utlized and click OK. Then, right after deactivation, activate that core again and click OK. Right now that core can be still used by the game but it is no longer overloaded. That helped me a lot when it comes to the 3-5 seconds freezes. I have Core i5 2500K 4.5GHz, GTX 1070 and Windows 7. Hope that helps.

Is this better than using the Shirase program?