Opening Ride - can't complete

Spent 5 hours endlessly being killed by my pursuers. Either the horse runs out of steam or I am killed. Am about to give this game up as being 66 I only have so much of my life left to waste on going nowhere (sic). Is there a knack to completing this ride, something that I am missing or what? Any guidance would be welcome. Thank you in advance.

3 Likes

You must run all the way down from the castle, than after you catch the horse hold CTRL button so the horse will be running on the road …after a while you will be shot into your leg by arrow from Kuman’s soldier. And then you must ride on the horse, crossing the bridge and going beside the river to the left. After a while you will arrived to Talemberk castle and you will be saved. That;s it and it’s not easy, you have right.

I had the same problem, it seemed my savegame was corrupt or something because i was unable to sprint, had to start over again to get it working.

1 Like

I found that sprinting on the horse but not staying on the path the whole time helped. Just running in a straight line towards your goal, whether it is on the road or not worked for me.

The small green bar is your horse’s stamina. When it gets low slow down and start zigzagging until it fills up again, then you can gallop away.

I simply cannot get past this point. Who on earth thought to design a game where the first time you ride a horse and don’t know the controls you are under fire. I have got so fed up with this.

1 Like

What I did was, once I was shot, I veered to the left off the road to not get any sentries that might be posted there… Made it to Talmberg :slight_smile:

after 3 hours of making no progress through this (beginning) quest, I found that packing it in, understanding that a bad purchase here and there is bound to happen, and opening Skyrim back up was my best option. Kudos to the developers for making such a realistic game…10/10! For fun however, the mark was disappointingly missed…1/10.

2 Likes

I created an account on this form just so I could come and tell you what I did to solve the problem with this opening scene. I uninstalled the game and requested a refund. This is ridiculous. You don’t drop such a skilled point on someone right at the beginning of the game. Not only that, but the characters look atrocious and all of the models are just clunky as hell. This should not have been released to the public yet. Beta.

1 Like

You can actually kill all of the CUMANs at the beggining of the game fairly easily once you have a horse, if you are a mount and blade veteran that it! Run down the hill from the castle grab a horse and now you can go to town. Canter or gallop at enemies and make sure they are slightly to the right of you (this makes swing detection easier i think) and press your stabby button. Run up and down the road until all the invaders are dead, but dont run too far out of the area or a stray cuman arrow will hit you. at the end of this you should be able to get quite a lot of armor which should help you survive the shootout along with a spear which will help you take down the other riders if you decide you want to fight them. when I did this i felt that a HERO was born.

3 Likes

dde

4 Likes

Thank you all for coming back guys, I did manage to do it in the end, no other skill than determination and the will to keep trying, I am afraid. I can understand however why so many people get really pissed off at this stage.

Its alll about the shift double tap to get up to speed whilst mounted, single tap when horse tired, double tap when full hp - the speed keeps you ahead of the archers

Just kill the bastards who killed your parents!

Could it be there’s some bug appearing in this scene? Because i see lot of people having trouble with it, while in my case i made it on the first try simply by running down the road…

I was also having a problem with acceleration, my horse simply didn’t gallop and I was always killed by first crossroad. I had to quit the game and load and then the horse was fast as a wind … (Xbox)

Fkn stupid, Cant even get to the river before getting killed.

2 Likes

OP, congratulations on your everlasting will to keep trying (over and over) and for completing the horseback escape!
Hope you are soon able to enjoy more of what this game has to offer.
Good for you for reaching out to a forum/community for advice (and answers) before giving up.
Also, keep in mind, there is a ‘prologue’ of sorts lasting several hours of gameplay and a few tasks to orientate the new player, so follow along with all that before trying to explore/quest, etc…
you will know when the prologue is done when you see the opening credits on the screen, like a movie

The game doesn’t tell you this, but you can also use the arrow keys instead of WASD. When doing that annoying Run quest on PC, just ditch the mouse and use your right hand to control the left-right horse movements with the arrow keys.

That initial quest is horrible and confuses many people and causes them to rage quit and even demand a refund. I hope this will be solved in future updates.

Ideally, the horse’s direction should be controlled by the right hand (i.e. the mouse) but if that’s “too easy” then maybe there should be some element of random “directional gravity” which pulls you to the side and forces you to constantly make slight adjustments.

1 Like

This^

Trying to control the horse with WASD while holding adjacent keys with the other hand doesn’t work well. I managed, after many abysmal failures to beat this quest using WASD, but ever since I learned the arrow keys also work, it’s SO MUCH EASIER to drive a horse with the right hand on the arrows and the left on L-SHF.

The keys to this quest are as follows:

  1. As soon as you regain control after the drawbridge is raised, RUN down the path without looking back. If you stop or look back, the Infernal Cuman Of Death will gut you. Fortunately, he gives up as you reach the mill.

  2. As you run past the 3 Cumans trying to rape Theresa, whistle (X key on PC). This will do 2 things. The Cumans will let go of Theresa and start chasing you, and the nearest available horse will move towards you. This gets you the “Cavalier” achievement. Unfortunately, the horse is now facing 180^ the wrong direction when you jump aboard. So immediately turn about and put the spurs to this nag. Just cantering until you reach the cut-scene of getting shot in the leg suffices.

  3. When you regain control after the cut-scene where you get shot in the leg, it’s all hammer down at the gallop. Don’t look back (there are 3 mounted Cuman archers right up your ass), just use <- and -> to weave a bit to avoid as many arrows in the back as possible. You’ll take a few more hits but don’t worry, if you make it to Talmberg, you’ll be healed up.