Patch 1,7 ruined the game once again


#1

Game was working like a charm on the highest details - I had no single error, or freeze. I have 50 hours of gameplay, I got to the middle of the story.
Suddenly - after patch 1,7, game is unplayable - after I load any save, I play 5 minutes and than the game freezes and crashes. All the time.
That’s not the first time - same things happened after previous patches.
Anyone having same problem? any fix?
I guess it has sth to do with the saves, but c’mon guys - I won’t start the new game every time you release a fucking patch!
Answer from some of the devs would be appreciated.


#2

A lot of forum goers here keep multiple saves from various points of the game so that if a quest is bugged/glitched after a patch/update; they can find out what is making contributing to the crash.

At this point, typical thread posts would ask you to a)start a new game (does it work when not loading the save data, ie, caused by a broken gme engine?)
B)try some old saves and see if they work… (if they do, a specific quest line may have become bugged, now we just need to figure out ‘when’)

Backup your save games, maybe send them to warhorse (if a new game works flawlessly), as they may care to figure out a way to get you up and running (it happens sometimes).

I would add; start a game, a walk around the map - dont fast travel… just let the game world crunch its daily cycles’ for 24 hours (in game) and see if that gets things rolling again.

I have found after every patch that the game benefits greatly from being able to run in an easy manner (eg walking around map) and I have never had a problem.
I do see performance lower after a new patch whilst a bunch of ‘back end’ game systems figure themselves out. After fourty minutes of gameplay, framerates are back where they should be.- i know framerate is generally governed by video card power/performance, but I have tweaked my machine to focus on raised minumum framerate numbers, and these are generally limited by cpu throughput, more so for cryengine based open world title like KC:D than others… after a patch there is more math going on than usual for awhile and a whole bunch of LOD transistions need to sort themselves out (like the game builds a world cache that can be affected by the version number)

After an hour of run time all hiccups/issues have sorted themselves out for me (and this has been a thing since patch 1.2/earlier)
I usually get a random family member to go for a virtual tour of medieval bohemia. No one has ever complained about time spent in this fashion, admittedly that was when ‘farkle’ (zilch etc(the dice game)) worked. It might ‘work’ presently but it isnt the same game by a country mile… :frowning:


#3

Hi,
Sorry to hear about your issues.

As @Whitedragem suggests, take all your saved files and playlines, zip them up, upload them somewhere (eg. filetransfer.io ) and send them either to our support (support@kingdomcomerpg.com) with link to this topic or send them to me here on forum as DM also with link to this topic.

Thanks


#4

Okay - I will give it a try and send to you some saves… It has to be latest patch that broke My Game. Everything was fine before that… Thank you for your quick reply!


#5

Help yourself; give useful help to the QA team;

Does the game run fine if a new playline is started?
Spend an hour checking this… now QA can tell if it is save data or a bad patch process…


#6

Isnt it a bit off this is the only case it’s happening though? Surely rig based.


#7

We have actually several reports about similar issues. And we are looking into them.
Any additional information is useful, though.


#8

Hahahahahaha Great example of talking without knowing, great job! :clap::joy:


#9

Yes. I started new playline. It doesn’t work.Always the same situation - you load any game, it works for 5 minutes, then freeze and you have to close the program. Just typical “KCD stopped working” error .


#10

I’m sure it’s the case of bad patch process… Because it never happened before - only after patch. Before patching all was working perfectly… The broke the game patching it, instead of repairing. That’s lame.


#11

My performance issues also started with the 1.7.1 patch so I hope that’s the problem (and a fix is on the way)


#12

Jesus you would need to be pretty ignorant to have missed all the topics that have popped up regarding crashes. Most attribute it to the tournament introduction in the latest patch.


#13

I think its the trigger added in 1.7.1 patch to check every 7 days for tournaments. My crashes started about 7 ingame days after i arrived in rattay and talked to the tournament master. Probably not a coincidence, but it seems one of the devs or q&a said its due to some item handling in the world… Hopefully they can hotfix it quick. Been waiting for weeks already.


#14

I have the identical situation with XBOX ONE. Loved this game since I got it in September. Had well over 50+ hours and had ZERO issues …until patch 1.7.1! As posted below, it seemed connected with the tournament. First crash came during my first sleep save. I restarted from a pre-tournament save, but it still crashes every five minutes, while doing nearly anything. I absolutely loved this game and now wish I could have blocked 1.7.1. and any and all future patches! So disappointing!


#15

I use the PS4. Since 1.7 Pribyslavitch turned against me.
I cannot access the privy behind the Rathaus, as there is a tuck gate protecting the chickens.
Butcher Brisket refuses to speak to me more often than not and turns against my trespass.
The archery master stopped trading arrows,
Add… most significant is that Kornelius trading appears as a trespass in the shop whilst the living area I can get to. So every time I try and go into the shop I get chased out.
The good news? Finally Brother Nicodemus finally woke up. He appeared to be in a permanent slumber after he helped the Merjohed illness, and the strike soldiers. We just laughed at the irritating coding changes but it can be irritating.
I could start another gameplay. But the belligerent NPC’s of From the Ashes DLC has meant my reputation in surrounding areas is now 100% Go suck on that Kornelius you ungrateful wretch!


#16

Oh yeah, forgot to report that. Frustrating


#17

Yeah, almost everything in PRIBYSLAVITZ is pretty fucked after last 1.7.0 update with no fix until now, 1.7.2

I wonder why, game coders just needed NOT to touch anything in Pribyslavitz if not to upgrade or fix bugs. But they created new issues from the scratch… How hard is that!? :joy:

Another example: no dice players either.


#18

Do you know if patch 1.7.2 fixed it? By now every patch literally ruins this game instead of repairing it. This is just silly from developers. After they release patch that will fix it, I’m gonna always play offline. No fucking patches anymore!


#19

Every platform has exactly the same problems and bugs with KC:D. And these shitty-patches cause it. They crash the game instead of fixing it. The DLC for this game are shit, very bad - boring, short. And they still want us to pay it! Good joke. I think the only solution is to play offline and skip every patch when they fix errors of this unfinished game.


#20

Every major patch or a patch has a risk of breaking save games.

It is unfortunate that it happens.