This game is a total mess - NO PROPER TUTORIALS! BUGS!

So I have got this game few days ago, and did not have much time to play, but once I have got time, I was furious when playing it.

First of all, you go to that Kunesh guy at the beginning to get your father’s money back. You go there just to get your ass kicked.
Then I found out by going to the center of that village that your friends are there and they can help you with that very first encounter to kick Kunesh’s ass…

Hi Developers, you should give us some directions/guidance… Just because you have made the game and know the solution and order of doing things, it does not mean we know and after an hour of spending trying to go back to Kunesh to try to win the fight I gave up and found out that with help of my friend I eventually won the fight with Kunesh.

Another bug that I encounter is when I am in Talmberg and I am trying to get out of the castle, I cannot because it requires me to find/get an armor which I got prior to that and sold it to the trader for money. Now I walked around to steal anything I could, went back to the trader sold other stolen stuff to purchase the shield back… I am still refused to be let out by the guard by the gate. And every time I am actually trying to bribe him, I lose money!!!

Please work on tutorials, give us hints on how particular situations could be solved, don’t tell us to go to particular place just to find out that we should go somewhere else first in order for the mission to be completed.

And please fix that Bug with the guard by the gate, I will try to get out of Talmberg once again but if I will be refused to be let out to Skalitz, then I guess I need to start over the game, as I am running out of money and possibilities to get out.

Also, the guard by the gate that I am trying to bribe is telling me that I need a shield and helmet… where the hell I get a helmet? I only found the shield in Talmberg which I sold and purchase it back from the trader to try to leave the castle.

There are many other things I kind of got frustrated with but at the moment those are my main concerns!

I think you’re gonna be struggling a lot with this game later on. Just few tips.

Kunesh has a locked chest inside his house.
One of your friends can help you with that.
You learnt to steal, why not try it on Kunesh.

I know about 4 solutions how to get out of Talmberg.
I didn’t successfully finish the armor solution but had no trouble finding a helmet. There are quite a few.
Try to look around the stone walls and bridge. 3 solutions there. 1 solution is by accident you avoid so much. Do a blatant mistake to get out.

Ok nice and simple. Punch that same guard in the face. Then surrender before he kills ya ass. Trust me it’ll work.

The game doesn’t hold your hand, and that’s a good thing. You don’t need to get the things from Kunesh. You can fail if you’re bad, and that’s fine. You can get your friends to help, or you can beat him, steal from him, pick flowers, do what ever you like to solve it.

If you want out of Talmberg, just jump off the bridge. Problem solved. You don’t need a shield, but you do need a helmet if you want him to let you out, and you can’t pass the speech, charisma, intimidation, or bribery checks. If you need someone to hold your hand, watch other people solve the quests on YouTube, there’s plenty there. Or, do yourself a favor, and have fun working it out for yourself.

2 Likes

Just as easy as you posted here, there is plenty of information about the game and user made tutorials.

There are loads of videos solely about the place you start, plenty of writes ups as well.

these are my favorite posts. I also cant help but lmao picturing kunish claiming another victim. ill bet if u ever do a 2nd play through, and go into it already knowing how to play you’ll destroy him. he got me too on my first time ever playing the game.

1 Like

Kunish has been going around the village telling everyone that your new name is Pussyhands. I think most of the village agrees you are not the most colourful crayon in the box, but this is a new low.

You need to sort Kunish out. Otherwise you’ll be getting your eye spat in for the rest of the game.

Best of luck Pussyhands.

2 Likes

you should try using your brain… instead of expecting the game to tell you everything.

And in the case of Talmberg, the game actually tell you how to get out. (you might need to speak to the Lady of the castle first)

2 Likes

It is a natural response to complain when we encounter a difficulty game. It took me 10 hours just to beat the tutorial mission and i almost gave up but i realized i was approaching the game wrong. I was so used to games being so easy and holding your hand that i had forgotten how to use my head, indeed we have all been conditioned by casual AAA games and our skill has been greatly diminished.

Warhorse should indeed keep working hard to fix bugs and make it more clear for new players while still encouraging them to use their heads. Even tho the game is over a year old now I believe if they continue to support it they will get more sales over time similar to how crysis did poorly at first but became one of cryteks highest sellers.

TLDR:
Its a hard game.
There are bugs.
Dont give up!

3 Likes

You can win the fight with Kunesh without your friend. You can also progress in the story without beating him. In fact, losing that fight is the only way to level lockpicking before leaving Skalitz.

You need more than two pieces of gear to fool the guard, and there are multiple copies of each piece. You just have to look for them. There are also other ways to get out of Talmberg.

You are used to games that are linear and designed to be simple. Kingdom Come is not that sort of game. Nothing you’ve described is a bug or an oversight. You should calm down and try to enjoy the experience. Not everything is going to be spoonfed to you. If that’s what you want, maybe try Skyrim or World of Warcraft.

No, you can not fight him at all, and still get the lockpicks from Fritz.

2 Likes

Oh my, oh my… that drunkard is such a badass! I bet you’ll feel feel ashamed of yourself when you see him later in game… haha

In fact, you’ll even look for him to help him with a proper job.

What I mean is if you beat him, you can’t get the ‘picks.

bro… what? You can just jump down the bridge in Talmberg to leave it. How could you miss that?

1 Like

About the guard armor. I just looked around for a guard room. Which is not hard to find btw, just walk around the walls you were guarding at night until you get in there and quietly sneak down the ladder and then pick lock the very easy lock. I only broke it once and that was my first time in the game. And get a full suit of guard armor and two shields next to it to steal. And with kunesh, after her beat me I went to dad to tell him that, he gave me money for the coal and said he will get him. And talked to mom to help my wounds.

You find a helmet in the chest you lockpick with full armor. with shields nearby. Every quest I did I just though logically. Someone beat me? Tell my dad, i need guard armor, look where guards are and sneak in and steal it. the door to it is not locked and is easy to sneak around if you think it’s too risky. I know i probably don’t understand as much as you because I done it before and you haven’t. But your problems you had I never ever had and never thought anyone would. I know most games give you a direct marker. But this is supposed to make it simulate medieval life. Think for yourself man. If you can’t guess what! We don’t live in the Medieval era! You can google it if you’re that stuck.

1 Like

You can, ive done it on my first play trough. But recently I guess they made it harder because I never was able to. I always run first strength then speech. You can but its bassically waiting for him to miss then you spamming swings.

To encounter difficulty is one thing, to start playing the game that does not give you any hints whatsoever. So you have to guess what, how and where to do things. No tutorials, no guidance whatsoever. It’s like asking someone who had never drove a car, to drive it without telling that person anything about process of starting and driving a car. Before that person would learn driving I guess would either crashed or burn pedals, gears, engine, etc. I am not saying the game should tell you exactly what to do, but at least give you some hints.

done it, but had to start game from scratch as I have lost too much money and other things.

thanks solved that issue before… the game still sucks when it comes to playability.

Well because I was following the bloody instruction to the letter. If its says go there and do this, I will go there and do this, it never said anything, if you cannot find this or do that, there is another way to do it…