Tried again 4 months later, still not having fun


#21

It’s probably my setup, but it’s impossible for me to do very easy lockpicking. I’m using a steamlink and bluetoothing an Xbox one s controller to do it. I’m not sure why, but when I engage both analog joysticks at the same time while lockpicking, the right joystick becomes very shaky. It doesn’t seem to be like this at all when I’m away from lockpicking as I’m able to move and aim the bow and arrow very easily… or maybe it’s just that the vibrations aren’t as catastrophic in that scenario. Either way, it’s impossible for me.

The one thing that is causing me problems that brings me to the forums today, is I can’t click on certain quest items and it’s quite game breaking and frustrating. I haven’t been able to interact with horses, and I’m on the prey quest right now and I couldn’t click the wine and cheese to get for Hans Capon. No problem, I just waited some time and failed that part of the quest. But now he’s tied up and I can’t click the use button to untie him.

As well I’m not sure if I shouldn’t be able to steal certain horses strewn across the land. But I haven’t been able to click an action on any of them yet. So I’ve just been running everywhere. I’ve googled these problems and people were having them several months ago. It’s quite surprising that they haven’t fixed such a bad game-breaking bug yet.


#22

Do you use any mod? Easy Lookpicking mod?
If yes uninstall and try again…


#23

I use an XB1 wireless controller on PC.
I agree lockpicking with it isn’t fun( even at higher skill) and revert to KB.
The rest would seem to be a bug for you.
I never had the problems you seem to have.
Have you tried some of the suggestions here and in other posts. Like verifying game from steam( or where you got it from), reinstall a fresh game and or removing old saves. XBone seem to have the most problems from reading posts all across the forum.


#24

it’s a challenge on consoles (PS4 here). i really didn’t want to use the drunk lockpicker perk but very hard locks were too difficult without it. :neutral_face:


#25

Found like you say, lockpicking and combat sucked. Playing Witcher 3 for second time great game.


#26

finally some1 else uses that perk… i was telling people about that when the game came out. i havent played in so long i dont remember exactly what lvl it is, 5 maybe. but u can be opening very hard locks in your 1st 3 lock picking perks if you pick the right ones.


#27

XBox One:
I found that venders, who do not have to worry as much about their reputation as those in big towns, will notice the stolen goods and comment on them, but will accept them. I haven’t checked yet, but probably at a discounted price.
The Millers seem to give a good price for items.


#28

Yeah, I usually go to the fridge and get a cold beer before attempting to do any lockpicking, but if you’re underage, that’s not a good idea.


#29

But the most fun.


#30

XBox One:
Maybe that’s the answer. Turn off the controller vibration setting.
I’ll have to check which way mine is set, but it seems I remember getting vibrations during lockpicking.
Vibrations would not help the process.


#31

My controller vibrates as pock is being ‘pushed to hard/far’, as a way to tell me to back down.

It what confirms to me that WH broke something about controller input and lockpicking around the 1.2 patch.

Since that patch lockpicking with controller is nearly impossible (unless done really fast).
When I let go of joysticks, controller vibrates as if pick stuck until pick breaks about a second later.
I had no issues with lockpicking on game launch and have seen the lockpicking ‘minigame’ be made impossible from that update.

In the same update they did a bunch of controller adjustments and obviously broke lockpicking on controllers since.
Waiting for a patch to rectify this overlooking - still havent tried the latest 1.6 patch.
Sure someone will slap themself when they realise- until then we can continue to have people like Kirksty telling people to get good or that the failing is on their part.
I can give actual testamony as to what has happened and possibly net a great discussion out of it… but it will be lost to typical forum loss of focus!

To confirm- I had no issue with lockpicking when game launched. It was a change to controller inputs that wrecked controller lockpicking.
Mine keeps giving phantom inputs every time I try to lockpick. Phantom inputs break picks and wreck minigame. Lockpicking quickly can alleviate the issue.


#32

I play on ps4. You just suck. Sorry. It’s not the game for you. They didn’t make this game for everyone. Lock picking on ps4 is simple and I really don’t get all the fuss. I can get open any lock other than some very hard chest. I opened the hard doors and chest with a level 3 in lock picking, so it’s player skill. I believe the old saying is “get gud”.


#33

I do thank you for your input but feel you’ve been as much help as a chocolate tea pot.

Xbox just seems extremely broken. Ps4 when you first start sucks. And on first 2 patches was like trying to do brain surgery but only being trained how to mop the floor it was impossible. But for ps4 they’ve found a nice place to be. I have no problem anymore with any lock. But do agree when trying to do any lock slowly it seems to punish you by jumping around a lot.


#34

agreed 100%. you are right about “git gud”


#35

another person complaining about lock picking dear god please help these poor souls.


#36

Wont get fixed if no one talks about the issue.
Obviously you people aaying ‘get good’ are so correct you neednt pay heed or try to understand there is a problem.

There is.
As my post (and a few others have highlighted), it easnt an issue with game in launch.
Lockpicking then was a fun minigame. (Irrelevant of success or failures).
Now watching picks break constantly from phantom inputs shows me the mechanic is broken.

Finished magician lord and gates of thunder and could do time crisis on a single credit. Pretty confident ‘player skill’ has nothing to do with the broken controller input.
For the record ‘lockpicking quickly’ isnt the roleplay game they are aiming for.
But if it makes you feel happy you can get around an issue- more power to you-
Lets keep an open mind here so that the forum can hold more than one (elite) viewpoint and also allow for discussions to happen.

If ye idjuts who just want to be deragatory of strangers whom you know nothing about cant read a few paragraphs- well then that wxplains your inability to understand- I CAN lockpick; doesnt mean the mechanic isnt broken, or hasnt worked better previously.
I just would like to see it fixed so everyone can ENJOY the game. (Without having to swap to keyboard mouse or do some clean movement by rote practise)


#37

In hardcore lockpicking is only harder if you go slowly. Since I mastered that skill to fullest in vanilla, I can just find the right angle and rotate fast. When I did this slowly in hardcore, it started shaking crazy and I lost the spot. It happens when going fast as well but for some reason I do not lose the spot.
I still think lockpicking is the easiest mini-game in KCD, the answer is mouse+keyboard.


#38

And that shaking isnt intentional. (When going slowly)

Controller inputs build up/get stuck.
There is an issue with polling rate or deadzone or something. For awhile the game DIDNT have the issue.
No doubt a few complaining about lockpicking are just trying to highlight it is NOW broken.

Broken doesnt mean impossible.
Just isnt what the devs wanted for us…


#39

Best way to hide it, in my opinion. And yes, if I had 2000 apples and one stolen, I would either eat it or shift in the pile.


#40

Have you considered that it might be your controller?
You have the same game as everyone else. Your problem is relatively unique.

Perhaps it is time to look at hardware?