Weapon not hitting


#1

So I can’t hit anyone with my sword I’m like 20 hours in and this just started. I can kill people with the bow and still parry with the sword just can’t do damage with it or punch 2.


#2

Neither can I I’m around the same gameplay time as you as well


#3

Right like I hit the person but it does zero damage


#4

Perhaps they are parrying or dodging or shield? Perhaps they have too much Armor and your sword doesn’t do enough dmg? Bows are indeed REALLLY strong a sword may have 79 base dmg, a bow plus arrows may have 204…


#5

Have you repaired your sword? If your sword (and armor) is damaged their stats get worse and worse. At 0 condition armor literally does nothing. Maybe swords are the same (I always keep mine repaired so not sure how bad they get).


#6

No I have a sword 100% condition and didn’t matter the armor of whom I attack the sword just phases through them same thing with other weapons


#7

i had the same problem when escaping from talberg before burying your parent there is a few fight and i had this bug too.
Attack did not connect and just go through ennemy with no effect at all.

I’m not playing this game anymore, too many game breaking bugs
i’d really like a refund


#8

i have exactly the same problem. not only the sword goes through the bandits without any damage, it also make no sound of any collision and even blocks. like there is no sword at all.


#9

Thank you for reporting, we will take a look into this issue. Can you attach some savegames to this thread? The forum does have an upload function when you make a post.


#10

i’m playing on ps4. never transfered saves from it, but i’ll give a try


#11

I’m on ps4 too


#12

Latest patch (1.03) sounds like it fixed it.

Did it?

I’m playing on ps4 too but haven’t had this issue so let me know.

Oh, just saw the moderator reply.

Well I’m staying tuned either way.


#13

I can confirm this issue on PS4 also. Started after new 1.03 patch. No weapon will make contact with a combatant. It just phases through them. If it is something they would block that animation happens but that’s it. Also happens in combat training. I have tried reloading unequipping and equipping different weapons and loading an old save. Nothing seems to help.


#14

I’ve seen similar reports today and someone posted a video of it. Turns out he was using a sword which had a high strength requirement and he kept hitting people with empty stamina bar. Maybe it’s the same thing with you?


#15

I had this in 1.02, me and a couple of others simply fixed it by restarting our ps4’s and unequipping all items, then participate in combat, in my case it was a training session so I didnt need armor, then after i re equipped all my gear and it works


#16

I heard unequip everything… sleep and then reequip and should work


#17

It’s not a strength or agility problem. I thought that too but it even happens with the wooden weapons. I’ll try the unequip sleep equip trick and report back after work. Hopefully that works.


#18

PS4 - I can confirm that closing the application and unequipping all clothing/armor, exit menu, then reequip all items again and it should work fine after that.


#19

So just to be sure, I should unequip everything, save, close the application, reload game and it should be fixed?


#20

If you are on xbox i encountered this bug as well, enemies would not take any melee damage. I had to force quit my game and relaunch it to fix this issue.