Weapon not hitting


#21

I can confirm on PS4 that if you unequip everything, save, close the application, load and start a combat training that will fix the issue. I started training with mine. I don’t know if that’s necessary or not but it worked for me. Hopefully it gets fixed with the next patch


#22

Same on Xbox one, my game was working fine until 2 back to back crashes now I’m un able to hit enemy’s with weapon or fists


#23

no way does my ps4 respond. I can poke around with R1 but no slash R2 doesn’t want to know


#24

Tried sleeping/ saving and restart. started new games with different attributes etc nothing works
So looking forward to this game, but having doubts now


#25

This game was pushed in an unfinished broken state and I want a refund


#26

I can not hit with a sword or fist,got into a fist fight could not hit him so i pulled my sword and as i am swinging like a mad man he walks right up and keeps right on punching my brains out!lol


#27

100% agree with you, they should have delayed release
but instead we got a broken product
a refund would be appropriate


#28

For the PC version, I had the same problem occur earlier today. All I did was simply equip a shield and used it to block. After that i was able to attack freely again with all weapons. Hopefully this helps someone.


#29

People! Hear me…Hear me now!..You will NEVER get your fucking money back…


#30

I am also having this problem. I had made it back to bury the folks when a bandit killed me because I could not land a hit with a sword. I quit the game and restarted it, same problem. I restarted a new game and from the very first fight with Kunesh (who I beat rather easily the first go around). I also could not land a hit. This is an absolute game breaking bug which needs fixed IMMEDIATELY. I knew about some of the bugs and was willing to take the chance because there seems to be so much right with the game. This is making the game UNPLAYABLE. I should note that I had a rather large update for the game this morning. These errors took place only after the update.


#31

There’s a fix to this on this thread. Unequip everything. Save. Load the game up. Go and do a live weapon training and then you’re good. Even if you die right after and load the last save that’s going to be BEFORE you do the training it will still be fixed.


#32

Thank you, I will try that!


#33

I had just killed runt in the steeple and decided to do some exploring of the map. Did a couple of side quests and then ran into some bandits. I took the first one out with a well-placed arrow to the head, then pulled my sword to fight the remaining 2 bandits. After a few minutes I found that despite hitting them several times both their health was at max. Then I realised that when I successfully land a blow it appears that sparks fly from their helmets but no damage is taken. I tried using the axe that I also had with me and even picked up bandit number 1s mace but all did the same. I persisted for around 20 minutes fighting these 2 bandits with a number of my skills levelling up but just could not kill them. Hand to hand does not work either

I have load up all previous saves and they all have the same problem now.

I’m playing on Xbox


#34

Not sure if it has been mentioned yet. I was able to fix this by hopping on my horse and poppin’ off a few sweet jabs. Dismounted mid-swing and the problem was fixed. Much faster if it works for you.


#35

If you slash with a sword vs metal armored person, you do very low damage, better throwing. Did you check if at your lvl can handle the sword?


#36

I have restarted the game 2-3 times after installing the latest patch and every time I’ve restarted and got up to the part of burying your parents I can’t do anything to the bandits…I ended up running away and firing arrows at them. The training with Bernard was unplayable, he tells you to attack with your sword, you can swing your sword at him for as long as you want, he just keeps saying “I don’t have all day.” Amazing game, just upsetting that I can’t play it right now.


#37

So… Any word on fixing this problem? because it has made this game unplayable


#38

This problem affected me too. I’m on PS4, in ginger quest. Wasted 2 hrs trying to kill 2 bandits, thought that I’m just lame and they are so good, but tried some fist fight and same - hits just go through opponent. Bow still works…
I think that problem is with game switching to constant bow mode - it has now gold dot reticle in non-bow mode (where it would be useful, but goes away when I switch to bow). I’ve seen one streamer to turn in on with console command for better bow aiming, so I guess this is for bow. Because it appears for melee now, I assume that in melee game thinks that bow is equipped and does not register any hits from weapons or unarmed punches.
Could you PLEASE check this suggestion and fix it or give method to revert it?


#39

On XBone I just restarted the console through menu and it worked.Hope this helps


#40

At least you can use R1… Xbox 1 x nothing is working! I can not hit anyone but with the bow… Man I paid all this money and like 10hrs into it and no work now hella mad blood!!! B