Weird black screen problem


#1

Hi,

I have a problem with weird black screen. When it happens then I couldnt see in front of me, only below me. It happens randomly, when walking, talking with NPC or fighting. When open and close inventory or map the screen backs to normal.

Thanks for help.


#2

Had the same with an overclocked GPU…Do you use any overclocking Tools?


#3

A friend of mine was having the same issue, turned out to be a windows issue. Once he update windows and cleaned his registry, the problems stopped. He has nothing overclocked, so we knew it wasn’t that.


#4

Yes. I use MSI Afterburner tool.


#5

try it with Default Settings and let us know if it works for you…


#6

Ok, I’ll try and let you know.

Thanks for a hint.


#7

After 3 hours of play on default settings, the bug did not appear. I hope it will be ok.

Thanks for a help.


#8

Ok. Now you can oc your gpu in small steps. In my case I oc the memory speed too much. Thanks for your feedback.


#9

Hello…
So i also got this problem, i turned off my CPU oc and i had no oc on my GPU so i tride to downclock it to see if that help, it didn’t…
I have downloaded the latest drivers for my nvidia card and windows is fully updated, i have tried different graphic settings but that won’t fix it.
So please help, i just bought the game and it seems wonderfull!


#10

Did you also reduce the gpu memory clock rate?


#11

Yep, -228 MHz GPU clock, -200 MHz GPU Memory clock


#12

What’s the Vendor of you GPU Card?


#13

Sorry, forgot to post system spec…

PCPartPicker part list /

CPU: Intel - Core i7-8700K 3.7 GHz 6-Core Processor
CPU Cooler: Cooler Master - Hyper H411R 34.1 CFM CPU Cooler
Motherboard: MSI - Z370-A PRO ATX LGA1151 Motherboard
Memory: Crucial - Ballistix Sport LT 16 GB (2 x 8 GB) DDR4-2400 Memory
Storage: Samsung - 850 EVO-Series 250 GB 2.5" Solid State Drive
Storage: Seagate - Barracuda Green 1 TB 3.5" 5900RPM Internal Hard Drive
Storage: Samsung - Spinpoint F1 DT 500 GB 3.5" 7200RPM Internal Hard Drive
Storage: Samsung - Spinpoint F1 DT 1 TB 3.5" 7200RPM Internal Hard Drive
Video Card: Asus - GeForce GTX 970 4 GB STRIX Video Card
Case: Antec - Nine Hundred ATX Mid Tower Case
Power Supply: Corsair - Builder 750 W 80+ Bronze Certified ATX Power Supply
Optical Drive: LG - GGC-H20L Blu-Ray/DVD/CD Drive
Operating System: Microsoft - Windows 10 Pro OEM 64-bit
Monitor: Philips - 271S4LPYEB 27.0" 1920x1080 60 Hz Monitor
Speakers: Logitech - X-530 70.1 W 5.1ch Speakers
Other: Coolmaster Masterkeys Lite L Combo RGB
Other: Malwarebytes Anti-Malware Premium (Lifetime Licens)

Generated by PCPartPicker 2018-12-24 11:01 CET+0100


#14

Ok. And now a Little detailed description of the Problem.
Is it from the start of the game of after some time in the game? Do you see anything while Looking around? can you make a screenshot?


#15

I will try to make screen shots and explain as good as i can…
BRB!


#16

Here are some screen shots:

this is just when i go into the game:

after not even 10 sec this happens:


I still hear the rain, i can move and interact with things but i can’t see.

if i go into the inventory screen like this everything is fine:

and this is what i looks like when i leave the inventory screen:

and just after a few sec:

it is only when it rains… if i go inside and “reset” (with inventory) i don’t have the issue.
i have however small black boxes that flicker by…

So i guess (and it is just a guess) that it has to do something with the particles (rain, dust, pollen, in-game of course )


#17

Let’s try:

Shutdown your PC. Full turn off. (to reset you GPU-Card)
Start PC and use MSI-Afterburner:
-50 GPU Clock and
-100 Memory Clock
-10CoreVoltage
Powerlimit leave by 100%

Start the game


#18

Hi…

So Afterburner won’t let me set -10 core voltage, i am already at “Min” on the scale.

With just the other two there was no change.


#19

Hmmm well….
last Thing we could do for now:

  1. Delete this Folder: C:\Users\%USERNAME%\Saved Games\kingdomcome\shaders\
  2. make a clean Nvidia Driver Installation:
    While Setup choose “Custom Install”

#20

BTW: You have to unlock Core Voltage Adjustment in the Settings: