1080ti, 6700k unstable gpu utilization and fps inconsistency

Hello there, i decided to run another playtrough with complete edition on steam after woman’s lot release and have encountered strange issue when game cannot utilize GPU properly. I could say it’s CPU bottleneck, but then i have tried disabling threads one by one and even with 1 core left everything stayed the same. GPU utilization goes up to 90%, can drop to 40’s% when turning around just in starting location. Before that i was running this game OK on GTX1070, not on Ultra settings but GPU utilization was normal.
Maybe someone can give me a bit of an advice on this? Because i have no issues at all with other games, even CPU hungry like recent Total War game.
I also run game on SSD, resolution is 2560x1440 and i have 16 gigs of RAM.

How much fps do you have? 25 fps are good playable and for ultra settings above normal. Remember ultra settings are thought only for future hardware and a 6700k is not future.

I cant agree that 25 fps is good and playable :smiley:
I have flucturations from 30s to 70s on ultra, and it doesnt help much if i drop settings to very high or lower.

Then the problem is not the game, but your unrealistic fps requirement. There are people who think 144 fps are not enough. For me they are just trolls.

There is definitely something wrong when game runs the same on different setting, or on 4 threads vs 8 threads

You should not disable or lower the amount of threads. Ultra, very high and high settings are optimized for graphics, while medium and low settings are optimized for best performance. So you have at least set everything to medium if you want 70+ fps.

Yes, other games runs smoother, but other games aren’t that rich on visuals and physics. For me KCD should have 10 fps on ultra settings with a RTX Titan. I want beta forest and the best looking visuals no matter how the performance is. In the future we are able to run this with 200 fps.

I get 20-50 MAX settings in Rattay i5 8600K 4.6Ghz and gtx 1060 and 1080ti is shitload of more powerfull even on 1440p u should get good frames. Try to oc ur cpu and see if it changes anything and there is some problems in game that it dont wanna utilize gpu very well aand game like more 6 cores than 4 even when u have those 8 threads but 6core6thread is better.

I have played the game in 3840x2160 on very high (some options on high) with a GTX 970 and i7-4770.

I thought this was a known fact by now but apparently not:
KCD is a CPU heavy game, not GPU (well, it is too, but at least it’s much more scalable in that regard), so even with a GTX 1080 Ti (that’s what I have too) you will never achieve good performance if your CPU isn’t top of the line too, KCD requires a (true) 8 core CPU to run (somewhat) great, with a 4core 8threads CPU the intel HT will “emulate” the 8 cores required by the game to run great, but it will never reach the performance level of a true 8 core CPU (Ryzen 2700X and +, Intel 9700K and +) .
What you want to do to help with the performance, is to set Object Detail, Physics, and Particles to medium MAX, and leave the distance sliders to their defaul values.
It will have popping yes, but that’s the best way to minimise drawcalls and reduce game objects handling.
For the rest, put everything in very high basically, but again, not ultra, ultra is meme and it actually looks worse sometimes (rain too copy pasted, lighting super glitchy in houses, etc…). Oh also Shaders to high instead of very high to reduce SVOGI’s grid resolution and disable Contact Hardening Shadows (which looks bad in this game sadly, too sharp and pixellated for close objects).

I will try that, thank you.
I dont remember the default position of distance setting though. Could you please remind?

of course, put the game in very high preset, validate, then it will choose the sliders positions for very high (it’s a good tradeoff quality / performance) and after that go to advanced, and do the manual configuration, don’t forget to disable motion blur lol.
tell me how it did it for you :slight_smile: That’s basically the settings I’m using, except I’m pushing objects detail a bit more cause I have a 6 core CPU (but I’m still limited by the fact I don’t have 8)


Just dit all that and asked a friend for a save file in Rattay, i loaded in and started a fight. it does seem to run better, but not for much. It’s playable ofcourse, but i remember clearly this game used to run much better when i had worse GPU - 1070, which to me is very strange. My friend also have 1080 card but 9700k CPU, he runs 100+ fps but on 1080p
I guess i will wait a bit longer, maybe another update or maybe i will upgrade PC later this year, for now i am too spoiled with high FPS in most games that this situation makes me a bit upset :frowning:

this mod will save your life, it will fix your fps it will make your game look way better

@Billy_Wellington just to be sure. Did you checked this post: [SOLVED] Performance - 40 FPS, LOW Settings, GTX 1080 Ti?

Yes i have seen it.
GPU is inserted properly.

Can you post a GPUz Sensor Tab or HwMon Screenshot while playing the game?

That PCI express lane trick is incredible ! I could have totally wasted months on an error like that ! Great job !

1 Like

1 Like

Thank you. Can you post the sensors tab too?

I have made a couple. Unfortunitely the only way to make it is all-tab and it shows a GPU usage at 30%, not very representative