[SOLVED] Performance - 40 FPS, LOW Settings, GTX 1080 Ti

Already submitted a ticket to Warhorse, but I thought I’d ask here as well:

About a year ago, I played quite a bit of KCD, had good fun, and importantly, good performance. Ran the game in ultra, 1440p borderless, at stable 60+ fps. Brilliant.

A couple days ago, I started playing KCD again, and was horrified to find my game chugging at 14 FPS.

In an act of desperation, I completely uninstalled the game, deleted the entire KingdomComeDeliverance folder from Steamapps\Common, and reinstalled it from scratch. The performance is still poor. At high-v.high settings, I get ~20 FPS. At low settings, ~50 FPS.

I’ve closed all background processes, and looking in WTM, the CPU is at around 40% utilisation (all cores), and the GPU at 100% flat. V-Sync is not enabled in-game or in NVIDIA Control Panel. You chaps have any idea what might be causing this abysmal performance? Already tried completely reinstalling my gfx drivers. Also tried deleting the config files, in case it was some tweak or setting there causing the issue. Also tried moving the game to my SSD.

The game looks like a potato, and chugs so hard it’s basically unplayable.

My spec:

  • i7 6700k, @ 4.0 GHz
  • GTX 1080 Ti
  • 16 GB DDR4 RAM @ 2400 MHz
  • Rendering in 2560x1440, borderless windowed

Solution: A while back I’d had some problems with my GPU, and when I’d taken it out, it appears it wasn’t seated properly when I put it back in. I took it out, put it back in, made doubly sure it was seated properly, and my problem was resolved.

It maybe be some other program or software. Did you install anything since that first time when you had 60 fps? Or did you upgrade hardware since? Maybe mods rewrote some of your settings that are by default now. I think game runs even better now than when I played in May last year. I also use i7 with GTX 1060. By the way, full screen might be better option than borderless windowed.

The performance gain between borderless and fullscreen is negligible. 2-3 FPS max.

I installed quite a lot of software probably, in the last year, but nothing which would have this effect I should think. I haven’t changed hardware in the last year, no. Mods couldn’t have changed anything, because I deleted everything, not only the game files, but also the config files.

I have ~35 fps in 4K on very high/ultra settings with RTX 2060.

That’s nice. 35 FPS is kidnda bad, but you’re running in 4K on v.high/ultra. That’s to be expected. Those are the results I’d expect with that card.

20 FPS on high/v.high, 1440p, with a GTX 1080 Ti is well below the performance the card should get out of the game, though.

For a RPG 35 fps is not bad. It’s absolutely acceptable. I don’t need 60 or even 144 fps! I can live very good with 30. That’s enough to explore the world. I don’t play fast action shooters. I like slow gameplay games where the goal is to get immersed and not a high score.

Most RPGs don’t have fast-paced, time-based first-person combat. And 30 FPS is noticably laggy to me, I find it quite jarring and immersion-breaking.

But ok, if you enjoy the game more at 35 FPS, looking gorgeous, that’s your choice. I don’t even have the choice, because I can only just barely squeeze out 50 FPS on medium-low settings. For some reason, I’m not getting the performance from this game that I should, with my spec.

The CPU never reaches 100% load, while the GPU is maxed out. Even on low settings, at 50 fps. I have more than adequate RAM, and my system never gets above 12 GB usage, of 16 GB (not including page file). In case the game wasn’t using all cores, and the CPU was actually bottlenecking, I overclocked my CPU to 4.4 GHz up from 4.0, to see if that improved performance. As I expected, not even slightly. For some reason, the game is using way more processing power on the graphics card than it should.

I’m not using HD textures DLC, or any graphics or texture mods.

I checked if triple buffering or something else was enabled in NVIDIA Control Panel, in case maybe there was some setting there causing it to be horridly inefficient. Nothing. Turned all the settings in NCP down to potato-mode, just in case, and not even a slight performance gain.

1 Like

Can you check if your GPU uses enough vram and if your clock speed is normal? I think your gpu isn’t performing normal. I got a 1080i aswell with a 8700k and If I play 1440 I get 80 or 90 fps. I agree with you, 60 fps is minimum on games. It just isn’t smooth.
Just see the difference https://www.testufo.com

According to HWMonitor, the clock speed is exactly what it should be, and the VRAM usage (assuming that’s what it is) is at 31%.

Everything looks normal. The GPU utilisation is 99% which suggests the GPU is working more or less flat-out, delivering all it can deliver… but that can’t be right, because I know a GTX 1080 Ti can deliver a lot more than 20 FPS at very high settings, 1440p.

I would say: bus interface load too high.

You really think my GPU isn’t seated properly? If that were so, wouldn’t it just not work?

And no other games are running anywhere near as poorly as Kingdom Come.

You can check it with gpuz to be sure.

What would be the telltale signs that the GPU isn’t seated properly?

Anything out of place there? I can’t see anything suspect.

I suggest a reseat of your gpu card.

Might as well try it, but I don’t think that’s the issue.

By reseat, you mean take it out and put it back in, or place it into a different PCIe slot?

I’m quite sure. You need 16x for optimal performance of your system.

Check your main board manual. Plug in to a 16x slot. If you are already in a 16x slot. Just take it out an put it back it.

It is in a x16 slot, according to the mobo manual.