Any way to remove blurriness (Not Motion Blur setting) when moving?

#1

Hello Warhorse Studios,

I am playing on PC at max settings with motion Blur disabled but whenever I move there is this fuzziness that is introduced on all objects. This was an issue in the beta as well. When I stand still, everything is perfect.

This is really starting to take away from the experience. I am one of those gamers who actually get sick from motion blur/fuzziness in gaming and I always disable that crap and find way to do so with console commands etc.

How can I remove that fuzziness?

Thanks

#2

Can someone from Warhorse Studios please comment on this?

I am digging the net for a fix but cannot find any. I am sure there is a specific CVAR that needs to be edited or a specific console command to get rid of this.

#3

open the console using the ’ key and type “r_AntialiasingMode” without the quotes.

That will output to the console what your current AA level is, note it and please let us know what the value is! Then type “r_AntialiasingMode 0” to disable all AA - the blurriness should be gone. Personally I use Mode 2 and find that it isn’t blurry, which is why I asked you to report what value you have by default - I expect it is 3 or 4.

3 Likes
GTX 1080Ti (390.77 WHQL Driver), i7 7700k @4.6Ghz, 16GB 3200Mhz DDR4 RAM, SSD. 1440p Performance unacceptable. Framerate drops in the 30-40s. Immersion breaking NPC, Object, Textures pop in at max settings, brief load before conversations, Microstuttering
GTX 1080Ti (390.77 WHQL Driver), i7 7700k @4.6Ghz, 16GB 3200Mhz DDR4 RAM, SSD. 1440p Performance unacceptable. Framerate drops in the 30-40s. Immersion breaking NPC, Object, Textures pop in at max settings, brief load before conversations, Microstuttering
#4

Hello agris, thank you for the reply.

i just checked and turns out it was 2. I tried 0 and the blur was indeed gone completely but now unfortunately, it is heavily aliased. A shame we do not have access to traditional MSAA without FXAA :frowning:

#5

@scorpgul

You can try forcing other AA modes using your driver, with KCD’s AA disabled.

FYI, if you want this and other settings to stick after closing / opening KCD, place a user.cfg file in the root KCD directory, and add commands such as:

r_vsync = 0
sys_MaxFPS = 75
r_AntialiasingMode = 0

etc.

Also, I noticed your other post about hardware / performance. I’ve been unpacking the .PAK files in the game to look at the settings, and I don’t believe even a system with your configuration can play the game with everything on Ultra. Indeed, Ultra is a setting that most likely can’t be played smoothly by any current consumer grade hardware.

The settings that impact image quality the most are Textures, all the draw distances, vegetation and object geometry. Try leaving all those at ultra/max, and setting everything else at medium. From there, dial up/down settings until you find which one(s) 1) impact the visual quality of the game FOR YOU, and 2) impact your performance the most.

I’ve found global illumination, shadows, geometry culling, and vegetation quality are some of the most demanding settings.

Another thing, unfortunately Anisotropic Filtering is tied to texture level, despite 16x AF not being a demanding setting at all. With Textures set to High, the max AF level is just 4x - so no matter how good your (edit: I’m writing this for the general public, I know that your 1080ti can use Ultra textures) LOD and draw distance settings are, you will always get murky textures. It’s only at Textures set to Very High and Ultra does 16x AF kick in, making long distance viewing look much crisper (with appropriately high LOD settings).

It’s a shame that AF is tied to the texture settings, and that the recommended GPU VRAM for a given texture setting isn’t specified, except it is in the game’s files. From sys_spec_TextureResolution.cfg

Texture set to Low is for 1 GB VRAM
Texture set to Medium is for 1.5 GB VRAM
Texture set to High is for 2 GB VRAM
Texture set to Very High is for 3 GB VRAM
Texture set to Ultra is for 6 GB VRAM

Those correspond to the Texture CVARS 1, 2, 3, 4 and 7, respectively.

Now look at sys_spec_Texture.cfg

[default]
; default of this CVarGroup
= 3

r_DynTexAtlasCloudsMaxSize=32
r_DynTexAtlasSpritesMaxSize=32
r_DynTexMaxSize=160
r_EnvCMResolution=2
r_EnvTexResolution=3
r_ImposterRatio=1
r_TexAtlasSize=2048
r_TexMaxAnisotropy=4
r_TexMinAnisotropy=4
r_TexNoAnisoAlphaTest=0
e_TerrainDetailMaterialsViewDistZ=80

[1]
r_DynTexAtlasCloudsMaxSize=24
r_DynTexAtlasSpritesMaxSize=16
r_DynTexMaxSize=100
r_EnvCMResolution=0
r_EnvTexResolution=1
r_ImposterRatio=2
r_TexAtlasSize=512
r_TexMaxAnisotropy=2
r_TexMinAnisotropy=2
r_TexNoAnisoAlphaTest=1
e_TerrainDetailMaterialsViewDistZ=60

[2]
r_DynTexAtlasCloudsMaxSize=24
r_DynTexAtlasSpritesMaxSize=16
r_DynTexMaxSize=120
r_EnvCMResolution=1
r_EnvTexResolution=2
r_ImposterRatio=1.5
r_TexMaxAnisotropy=8
r_TexMinAnisotropy=8
r_TexNoAnisoAlphaTest=1

[4]
r_TexMaxAnisotropy=16
r_TexMinAnisotropy=16
e_TerrainDetailMaterialsViewDistZ=100

[7]
r_TexMaxAnisotropy=16
r_TexMinAnisotropy=16
e_TerrainDetailMaterialsViewDistZ=100

So default is High quality textures (CVAR 3) with an AF of… 4x. That was a bad call.

Thankfully, you can manually specificity r_TexMinAnisotropy and r_TexMaxAnisotropy via the console and user.cfg, per the instructions above. If people who have to play at High texture level or lower could set their AF to 16x easily, I think it would make a lot of the texture quality complaints go away. Similarly, if Warhorse would be upfront with what VRAM is need for a given texture setting, they would reduce a lot of the pop-in complaints. I think a lot of the pop-in problems has to do with swapping textures and geometry data out of a page file in RAM or, even worse, the hard disk, to VRAM. So people playing on Ultra Textures with 16 GB of ram and 4 GB of VRAM are likely facing a double-whammy - the game is having to page some game data that should be in RAM to the hard disk, and some geometry and texture data ise being paged either from HDD to RAM to VRAM, or from HDD directly to VRAM (I’m not as familiar with VRAM paging as I am with regular ram), either way it will cause some noticeable pop-ins.

FWIW, knowing this, I’ve got all my LODs and draw distances 3 pip shy of max, and am playing on Very High textures (w/ 4 GB VRAM and 32 GB RAM) and have no pop-in.

1 Like
Tuning-Tipps PC Hardware / System
Tuning-Tipps PC Hardware / System
#6

Is there any way, how to turn it motion blur and similar effects off on PlayStation? My wife gets dizzy from that.

#7

Thanks a lot!!!

I’ll try tweaking with my personal user.cfg accoring to your Information you provided. Thanks, great work!